Bug #53603 Installation of MySQL WorkBench has error
Submitted: 12 May 2010 15:10 Modified: 4 Mar 2011 17:01
Reporter: Sebastien Caisse Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.29 OS:Microsoft Windows (Versions w/ Firewall)
Assigned to: Johannes Taxacher CPU Architecture:Any
Tags: firewall, installation, windows

[12 May 2010 15:10] Sebastien Caisse
Description:
If the firewall service is not runnning on a machine, the installation outputs a dialog box indicataing that it can't connect the to firewall.

Before trying to connect to it, the installattion should check wether the service is running.

It might be pertinent to output the message if a firewall is supposed to be running and is not, but if it was shut down, then it is irrelevant.

How to repeat:
Stop the firewall service and run the installation.
[15 Jun 2010 16:57] Jason Sachs
Why is this S3? It offers absolutely no information on what to do about the bug, and leaves users like me with no clue how to get the install to work.
[15 Jun 2010 19:51] Sebastien Caisse
Because 99% of users do not disable the Windows Firewall (or they have another software that replaces it in function fully) - and when you do Windows "Alerts" keeps nagging you that you need one, so you also need to disable that...

At least the MySQL WB installation indicates that the serivce is not running (unlike some Microsoft installations which simply quits silently and when you look at the log, all you see is a wacko error number you need to look up on Google...)

Anyhow, just restart your firewall service for the time the installation runs and stop it once it's done.
[21 Jul 2010 15:59] Michael Garcia
Well I would like to differ on the issue of windows having the FW service almost always on - on amazon EC2 servers it is off and it annoys people, see http://me-ol-blog.blogspot.com/2010/07/mysql-workbench-install-annoyance-you.html
[12 Oct 2010 19:46] Sebastien Caisse
Still there, just "poking" as it's *really* annoying to those who don't use it.
[23 Feb 2011 18:11] Lee Clemens
Still occurs in 5.2.31.

This is a serious issue, as it prevents installation.

Why should MySQL Workbench REQUIRE me to be running the Windows Firewall?

If it is trying to add an exception for itself - it would be unnecessary as I am not running the Windows Firewall.
[3 Mar 2011 13:59] Johannes Taxacher
fix confirmed in repository
[4 Mar 2011 17:01] Tony Bedford
An entry has been added to the 5.2.32 changelog: 

        On Microsoft Windows, if the Windows Firewall application was 
        not running, installation of &workbench; would halt with an 
        error dialog indicating that it was unable to connect to the 
        firewall.