Bug #5360 During Backup Project Maintenance an Access Violation occurs
Submitted: 2 Sep 2004 2:35 Modified: 1 Jun 2005 12:25
Reporter: Christiaan du Plessis Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S2 (Serious)
Version:1.0.11 OS:Microsoft Windows (Windows 2000)
Assigned to: Vladimir Kolesnikov CPU Architecture:Any

[2 Sep 2004 2:35] Christiaan du Plessis
Description:
First error:
When I create a Backup project, add a schema, go to the advanced option, select Single Transaction and press Save Project I get the following error:
- Access violation at address 0058A877 in module 'MySQLAdministrator.exe'. read of address 00000011

Second Error:
The bug affects all Projects and does not allow you to save added schemas to any subsequently created projects. You can add the schema but it disappears when you select another project and come back to the one you have changed. 

In some cases the whole administrator closes without any messages when you add a schema and press save. 

I am running the following:
MySQL Administrator 1.0.11
MySQL Server 4.0.20a-nt via TCP/IP
Windows 2000 Service pack 4 build 5.00.2195

Christiaan

How to repeat:
First Error:
create a Backup project, add a schema, go to the advanced option, select Single Transaction and press Save Project.

Second Error:
Add another project and try and add a schema.
[2 Sep 2004 9:57] Michael G. Zinner
Thanks for reporting. Could you please upgrade to MA 1.0.12 and verify if the bug is still present there.

The problem you describe occured when the Taskplanner windows service was not started before using MA.

We added a check for this and display a warning dialog in 1.0.12, so the Access Violation does not occur anymore.

Thanks.
[3 Sep 2004 3:18] Christiaan du Plessis
Hi there,
Thank you for the update. I have installed 1.0.12 and it resolved the error at hand after starting the Task Scheduler service, but unfortunately the following now happens:

- I was able to add schemas to 2 of my projects and schedule the first for a weekly run. 
- I then proceeded to schedule the second for a monthly run (1st of Every month @ 23:00), when I pressed save the message that the task scheduler is not running appeared. I checked the service and it is still running, I restarted the Task Scheduler service and tried again, but the same message appeared. I closed administrator and started it again but the message still appears, even though the task scheduler is still running. 

I check the tasks and both were created sucessfully, I just can not maintain ay of the projects any more.

Regards

Christiaan
[7 Sep 2004 17:08] Townsend Clarkson II
I am having the same error.  The backup task have been succesfully scheduled. Then everytime I go to view the scheduled backup I get a message that the Task Scheduler is not running.
[13 Sep 2004 3:26] Michael Watson
The general administration functions work just fine. But when I try to run a backup, I get the following message in a popup: 

=-=-=-=-=-=-=-= 
The connection to the scheduling service cannot be established. Please make sure you have the "Taskplanner" service activated and running. This can be checked with the Computer Management that is accessable in the Administrative Tools in the Control Panel (WIn2k/XP). 

System Error Nr. 234 
More data is available 
=-=-=-=-=-=-=-= 

There is no Taskplanner service, so I'm not surprised that it couldn't connect to it. There is a "Task Scheduler" service, though, and it is running. Shutting down and restarting either the service or the MySQL Administrator doesn't help. 

Bottom line.  Can't administer the Backup Projects or run backups through MySQL Administrator any more.

More info: When the Tray Monitor starts, some portion of it crashes with the message: 

=-=-=-=-=-=-=-= 
Access violation at address 77F82BF6 in module 'ntdll.dll'. Write of address 00404F46. 
=-=-=-=-=-=-=-= 

The tray monitor is still running but only displays a partial menu, say the first 30 pixels of the left side of the menu. The top menu item loads the MySQL Administrator correctly. 

Cheers! 

Michael W.
[13 Sep 2004 14:20] Corey Tisdale
I also have the taskplanner service problem. I installed Administrator and it backed up fine for two days, and then all of the sudden, Administrator cannot connect to the taskplanner service. I know its already been verified, but I thought I would keep up the talley up. I also am running 1.0.12
[15 Sep 2004 15:48] Fabio Ottolini
I am using version 1.0.12 and have the same problem on 2 Win2K box. Something related to "Taskplanner", which I have never heard of.
Besides that, after I have created a backup project, I am receiving this error message a lot, even when I try to remove the project! This does not make sense, of course.
[17 Sep 2004 16:17] [ name withheld ]
Hello all,

It seems that the access violation problem occurs only when one does not add any schemata into the backup content list (through the "Backup Project" tab).

In that particular case, no check is performed by the program prior adding the task to the task planner (aka task manager) and once the task starts, an access violation is issued.

In order to resolv this problem, remove any schedulated tasks from the windows task scheduler, then reconnect with the MySQL Administrator and make sure all tasks do have schemata into the backup content list.

There is obviously a bug surrounding this access violation but I guess its severity can be decrease if one follows the mentionned "workaround" above.

Cheers

pasde
[1 Oct 2004 17:35] Harry Sklar
I'm also getting the same "Taskplanner" error and problem, using version 1.0.13 on Win2000, connecting remotely to a SuSE Linux server. 
After saving, closing MySQL Administrator and then reopening Administrator again I get the pop-up error as descriibed here by others, find the items in Advanced Options tab grayed out (though some of my settings are still there), and ALL of my settings gone from the "Schedule" tab (with everything also grayed out and unchangable).

After saving the backup project, I have indeed found a item referenced to it in the Windows Scheduled Tasks list (one for each scheduled backup project). The settings appear to be correct, the "Enabled" checkbox is checked. The Comments field says "Created by NetScheduleJobAdd."
The "Run" field says (specifically named items in [brackets] changed for this posting):

"C:\Program Files\MySQL\MySQL Administrator 1.0\MySQLAdministrator.exe" "-UDC:\Documents and Settings\[directory name]\Application Data\MySQL\" -c[remote Linux servername] -bp[backup project-name] -bt[network drive-letter]:\[directory name]\[directory name]\full_backup\ -bx[backup project-name]
[5 Oct 2004 19:53] Neil
I found that if you rename the scheduled tasks from at1, at2, I can create additional tasks with out any problems.

Thanks
Neil
[11 Oct 2004 16:36] Tanya Dubay
Hello,

I recently began using MySQL.  I am still having the same issue others have had regarding scheduling backup tasks.  I am still having this error even though I have made sure to have the schemata into the backup content list.

I deleted the task out of Windows task manager and rescheduled them using MySQL Administrator.  Am I missing a step?

Thank you in advance for your time.
[22 Oct 2004 3:57] Ryan Carey
I had the same problem.  As previously stated, you have to rename the Scheduled Task that the MySQL Administrator creates.

Start > Accessories > System Tools > Scheduled Tasks

MySQL Administrator creates the scheduled tasks under the name of "At1" for the first job and "At2" if you add a second backup.  It appears this "Taskplanner" error only occurs when you have 2 scheduled tasks.  

I've found the only problem with renaming the scheduled tasks is the "Schedule" tab becomes grayed out since it's looking for the at1 or at2 job.  I've also gotten an error when trying to delete a backup project after I changed it's name, however this doesn't always break....however if you change the name of the task from the default at1 or at2, it will not actually delete the scheduled windows task.  In addition if you rename the job and then make a change to the backup project and press "Save Project" it will create a new job under the at1 or at2 name, thus you have 2 backups.
[22 Oct 2004 17:59] Christopher Gonzalez
I went ahead and renamed at1 and at2 to at1a and at2a, respectively, and sure enough I don't get the error anymore.  Will the scheduler automatically run these tasks though?  It wasn't before, and I had to click Run... for each task to make them work.

This is under both Windows Server 2003 and Windows 2000 Server Professional, using 1.0.13.

Chris
[3 Nov 2004 14:01] Bretton Eveleigh
Hi all,

I have experienced the same backup problems. I'm sure the MySQL admin developers will sort this out soon, but in the interim I have found it works fine to setup the initial schedule using the MySQL Administrator, then renaming the scheduled task 'At1' in 'Schedule Tasks' Windows application and administering it from there. It doesn't matter if MySQL Admin cannot 'see' it anymore as you can administer it via 'Schedule Tasks' which allows you more control over back frequency and intervals anyway.  Using the 'Schedule Tasks' app you can set your backups to run every hour or even every couple of minutes where as the MySQL admin allows a smallest interval of daily.

If you want to change MySQL specifics then delete the 'scheduled task' entry via the 'Schedule Tasks' app and then recreate it from MySQL Admin.

I noted that MySQL Admin 1.0.14 is available, will check if this ver. resolves the issue.

If you are using MyISAM table types on a Windows system you may also consider using the Windows Backup tools. I used this method successfully for over a year without any hassles.

Regards,
MySQL Fan ;-)
[23 Feb 2005 9:58] Spyros Iordanopoulos
MySQL Admin ver 1.0.19. 
I'm trying to schedule a Backup project but it doesn't work at all. The status at Windows "Schedued tasks" is "Could not start".
The type of the tables that I use, is InnoDB.
If anyone can help me, please response ASAP.
Thanks
[17 May 2005 12:13] Tapio Mattila
Hi all,

Found out that at least MySQL Admin versions:

* 1.0.19 and 
* 1.0.20

'removes' the password of windows scheduled task, hence we will get 'could not start' error in task scheduler. It looks like the old password would be kept, but in fact it does not keep it. On the other hand if you do specify the password, when prompted, the windows task will be successfull.

Tapio Mattila
[1 Jun 2005 12:25] Vladimir Kolesnikov
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html