Bug #53528 Failure of test 'rpl_ndb_typeconv_*' on Solaris Sparc
Submitted: 10 May 2010 7:32 Modified: 26 Oct 2010 8:17
Reporter: Kent Boortz Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Cluster: Replication Severity:S3 (Non-critical)
Version:mysql-5.1-telco-6.3 OS:Solaris (Sparc)
Assigned to: Assigned Account CPU Architecture:Any
Tags: 6.3.33, 7.1.2, 7.1.3

[10 May 2010 7:32] Kent Boortz
Description:
Regression test 'rpl_ndb_typeconv_all' and 'rpl_ndb_typeconv_lossy' fails with

@@ -60,7 +60,7 @@
 SET('master','s        SET('master','s ALL_LOSSY,ALL_NON_LOSSY         <Correct value>
 SET('0','1','2'        SET('0','1','2' ALL_LOSSY,ALL_NON_LOSSY         <Correct value>
 SET('0','1','2'        SET('0','1','2' ALL_LOSSY,ALL_NON_LOSSY         <Correct value>
-SET('0','1','2'        SET('0','1','2' ALL_LOSSY,ALL_NON_LOSSY         <Correct value>
+SET('0','1','2'        SET('0','1','2' ALL_LOSSY,ALL_NON_LOSSY         '' != '5'
 SET('0','1','2'        SET('0','1','2' ALL_LOSSY,ALL_NON_LOSSY         <Correct value>
 TINYINT                TINYINT         ALL_LOSSY,ALL_NON_LOSSY         <Correct value>
 TINYINT                SMALLINT        ALL_LOSSY,ALL_NON_LOSSY         <Correct value>

How to repeat:
Run the test on Solaris Sparc, 32 or 64 bit
[8 Jul 2010 17:18] Joerg Bruehe
This failure is also seen in the Cluster-7.1.5 build.
[26 Oct 2010 6:24] Jonas Oreland
This is a duplicate of http://bugs.mysql.com/bug.php?id=52131,
and that has now been merged in 6.3.39, 7.0.20 and 7.1.9.

Hi-jacking this for documenting 52131 for cluster
(unless it will auto.matically, in which case you can just close it jon)
[26 Oct 2010 8:17] Jon Stephens
Per Jonas' comment, I'm closing this as a duplicate of BUG#52131, which I'll be documenting shortly.