Bug #535 MySQL Server Crashes When Editing the User Tables
Submitted: 29 May 2003 7:50 Modified: 29 May 2003 10:56
Reporter: [ name withheld ] Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:4.0.13 Win OS:Microsoft Windows (Windows XP)
Assigned to: CPU Architecture:Any

[29 May 2003 7:50] [ name withheld ]
Description:
I've used MySQL in the past and I always have to fight it.  The first time took about three days to make it work, this time just one until I could edit passwords.  It originally refused to even run when started as a service, but I managed to fix that.  Anyway, when I try to edit the user table with either the command-line interface or phpmyadmin, the MySQL server will crash without fail.

It will crash when:
1) Trying to insert a new user
2) Trying to edit an existing user

It will not crash when:
1) Editing any other table in any database
2) Deleting a user

I've had a problem getting user permissions set up.  I managed to get one called general for localhost without a password, but now it will just crash if I try to add/edit a user.

http://www.tim.xfury.net/sqlcrash.gif

How to repeat:
I open up the MySQL command-line interface and try to use:
SET PASSWORD FOR general@localhost=PASSWORD('thepasswordIuse');
And it will tell me that the user doesn't exist.
SET PASSWORD FOR general=PASSWORD('thepasswordIuse');
Once again it will tell me it doesn't exist.

Then I try:
UPDATE user SET Password=PASSWORD('thepasswordIuse) WHERE user='general';
And the server will crash.
I tried the same command through phpmyadmin and the server will crash.
If I try to insert a new user with phpmyadmin, it will also crash.

I've done all of these things multiple times.
[29 May 2003 10:56] Miguel Solorzano
I wasn't able to repeat.
Could please send me a repeatable test case when the server crash.

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 5 to server version: 4.0.13-max-nt-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

<cut>

mysql> SET PASSWORD FOR general@localhost=PASSWORD('mypass');
Query OK, 0 rows affected (0.00 sec)

mysql> UPDATE user SET Password=PASSWORD("thepasswordIuse") WHERE user="general";
Query OK, 2 rows affected (0.03 sec)
Rows matched: 2  Changed: 2  Warnings: 0
[29 May 2003 14:24] [ name withheld ]
I forgot to add this information:
I copied the data from my older MySQL (verion 3.23.51-win) server over the data for the new one (just the data folder).  If this could be some sort of incompatibility between the user databases between the two, that might be my problem.  If needed, is there some sort of way for me to send the dataset to you so that you can test if that's the problem (if you need it)?
[29 May 2003 14:38] [ name withheld ]
My apologies.  I've managed to find the problem and I regret (in the respect that I wasted your time) it was not a bug.  It was in fact an incompatibility between the user tables of the different versions.  Thanks for helping me and thanks for making such a solid product.