Bug #53349 Unable to rename a table
Submitted: 1 May 2010 22:17 Modified: 2 May 2010 8:53
Reporter: Mattias Twedmark Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.19 OSS Beta Revision 5680 OS:Microsoft Windows (Win 7 Professional)
Assigned to: CPU Architecture:Any

[1 May 2010 22:17] Mattias Twedmark
Description:
When renaming a table in the SQL Editor it won't change name.

How to repeat:
In the Overview, right click any table and select "Alter Table", in the "Table" tab change the name of the table and hit Apply.

Nothing happens and the result presented in the lower left corner is;

"
No changes to object were detected.
SQL: 
"

Suggested fix:
Check if the tablename has bin changed and in that case generate a "RENAME TABLE [from] TO [to]" and execute...
[2 May 2010 8:53] Valeriy Kravchuk
This is a duplicate of Bug #52786.