Bug #53332 ChannelException('Connect failed'.)
Submitted: 30 Apr 2010 18:48 Modified: 3 Jun 2010 20:42
Reporter: Rogelio Alvarado Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.2.20 OS:Microsoft Windows (vista home premium)
Assigned to: CPU Architecture:Any
Tags: can't connect via ssh

[30 Apr 2010 18:48] Rogelio Alvarado
Description:
at first it worked fine but now (1 day later) that I try to connect to the server, it prompts and alert but sometimes the mssages changes:
ChannelException('Connect failed'.)
and
'reading initial communication packet', system error: 0

I've checked my windows firewall and nothing is blocking the application and noone has changed network's firewall or something like that.

How to repeat:
configure a connection via ssh
and use the software, then restart computer.

Suggested fix:
no ideas
[3 May 2010 20:42] Johannes Taxacher
Does this happen after leaving Workbench running for a longer time or also when you restart workbench?
does creating a new profile and connecting to that work (like it worked at first when you created the profile, as you reported)?
thanks in advance
[8 May 2010 14:55] Robert Brasington
I'm seeing the same problem on Windows 7 64-bit.  Can't get the SSH tunnel to work in any cirumstances.

If I use Putty to create an SSH tunnel, then Workbench Query tool connect fine, but using the same connection, the Administrator tool won't connect.
[3 Jun 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".