Bug #53244 Execute Current Statement shortcut (CTRL+F14)
Submitted: 28 Apr 2010 11:35 Modified: 29 Apr 2010 17:36
Reporter: Francesco Carusi Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.20 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: keyboard, shortcut

[28 Apr 2010 11:35] Francesco Carusi
Description:
The keyboard shortcut for "Execute Current Statement" in the SQL Editor appears to be CTRL+F14 in the Query menu. I do not have a F14 key and when I used the old  shortcut (CTRL+ENTER as of version 5.2.19) all the statements were executed, not only the current one.

How to repeat:
- Open the Query menu in the SQL Editor, check the shortcut.
- Enter more than one query in the script editor and select CRTL+ENTER.
[28 Apr 2010 11:38] Valeriy Kravchuk
Thank you for the bug report.
[29 Apr 2010 17:36] Alfredo Kojima
this is caused by the same issue to be fixed with bug #50911
[30 Apr 2010 12:17] Valeriy Kravchuk
Bug #53314 was marked as a duplicate of this one.
[3 May 2010 20:45] Johannes Taxacher
Bug #53333 has been marked as duplicate of this one