Bug #53127 Can't import 90mb MySQL dumpfile
Submitted: 23 Apr 2010 20:34 Modified: 3 Jun 2010 9:14
Reporter: Neil Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.18, 5.2.19, 5.2.20 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: crash, MySQL, restore, workbench

[23 Apr 2010 20:34] Neil
Description:
I'm using work bench to restore a 90mb MySQL dumpfile, containing 1,000s of INSERT statements.  However, on pasting the contents of the dumpfile in the SQL Statement screen, I get a exception stating "Exception of type 'System.OutOfMemoryException" was thrown.

How to repeat:
Create a dumpfile around 90mb and attempt to restore using the SQL statements screen under Workbench.
[23 Apr 2010 21:32] Miguel Solorzano
Thank you for the bug report. Could you please try 5.2.19 version?. Thanks in advance
[26 Apr 2010 8:02] Neil
We upgraded to the latest version 5.2.19 and the same error message occurred.
[26 Apr 2010 8:08] Valeriy Kravchuk
Please, send the results from Help > System Info menu item.
[28 Apr 2010 13:33] Neil
The result of the command was 

MySQL Workbench OSS for Windows version 5.2.20Cairo Version: 1.8.8Rendering Mode: OpenGL is not available on this system, INTERNAL ERROR, contact the authors.OpenGL Driver Version: Not DetectedOS: Microsoft Windows XP Professional Service Pack 3 (build 2600)CPU: 2x Intel(R) Pentium(R) Dual  CPU  E2200  @ 2.20GHz??W ?W ?W?Z?;??Z, 2.8 GiB RAMVideo adapter info:Adapter type: NVIDIA GeForce 7100 / NVIDIA nForce 620iChip Type: GeForce 7100 / NVIDIA nForce 620iBIOS String: Version 5.73.32.11.07Video Memory: 524288 KB

Also, we upgraded to latest version of MySQL Workbench 5.2.20 - but still the same problem
[29 Apr 2010 8:49] Neil
Further information :

It would appear using the Import routine does work fine, the problem remains when pasting 90mb worth of INSERT statements into the MySQL Workbench: SQL Editor
[29 Apr 2010 13:05] Susanne Ebrecht
This could be related to bug #53186.

Is the script always breaking after 32768 characters?
[29 Apr 2010 13:18] Neil
Yes this could be the case.  I don't know the exact number when it occurs, but the file is 90mb in size.
[3 Jun 2010 9:14] Sveta Smirnova
Thank you for the feedback.

This is duplicate of bug #53190