Bug #53104 Load data infile fails to read files placed under directories in a drive
Submitted: 23 Apr 2010 9:59 Modified: 26 Apr 2010 19:52
Reporter: Anil Konsal Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.19 beta OS:Any
Assigned to:

[23 Apr 2010 9:59] Anil Konsal
Description:
Load data infile fails to read files placed  under directories in a drive

How to repeat:
take any csv file and place it under d:\CSVs directory, then try to import the data in mysql using 'Load Data Infile' command
[23 Apr 2010 10:15] Valeriy Kravchuk
Are you working with local or remote MySQL server? Please, specify also the exact LOAD DATA statement used.
[23 Apr 2010 10:18] Anil Konsal
i am working with local data. here is the statement.

load data local infile 'e:\CSVs\agents.csv' into table customers_raw
fields terminated by ','
enclosed by '"'
lines terminated by '\n'
( company_name,name, address,city,zip,phone,mobile,email);
[26 Apr 2010 19:52] Sveta Smirnova
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Please read at http://dev.mysql.com/doc/refman/5.1/en/load-data.html:

Windows path names are specified using forward slashes rather than backslashes. If you do use backslashes, you must double them.