Bug #53035 'Export as PNG' behaves as 'Open Model'
Submitted: 21 Apr 2010 19:25 Modified: 22 Apr 2010 10:52
Reporter: David Btm Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.19 rev5680 OS:Microsoft Windows (XP Pro SP3)
Assigned to: CPU Architecture:Any
Tags: export, not, pdf, png, postscript, svg, working

[21 Apr 2010 19:25] David Btm
Description:
The 'Export as PNG' command just behaves as the 'Open Model' command. So it does not export an image of the current diagram but it tries to open the filename you have just typed in in the save dialog box.

How to repeat:
A model is opened and you can see your diagram on the screen

- choose 'File' > 'Export' > 'Export as PNG...' from the menu
- type in a filename for the PNG file
- click the 'save' button

A dialog box shows up :
 "Opening another model will close the currently open model.
  Do you wish to proceed opening it?"
                          Yes | No

If you select the 'Yes' button, then you have the following error :
 "Could no open file <your path>\<filename>.png: No such file or directory"
[22 Apr 2010 0:18] David Btm
Actually, all 'Export as...' commands (PNG, SVG, PDF, PostScript) behave this way.
[22 Apr 2010 10:52] Johannes Taxacher
this is a duplicate of Bug #52909