Bug #53001 Can't start server administration
Submitted: 20 Apr 2010 18:35 Modified: 2 Jun 2010 15:03
Reporter: Alexandre Gomes Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:5.2.16 OSS Beta, 5.2.20 OS:Microsoft Windows (Server 2003)
Assigned to: CPU Architecture:Any
Tags: localhost, MySQL Workbench, remote desktop connection

[20 Apr 2010 18:35] Alexandre Gomes
Description:
Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
When in a local network connect through remote desktop connection to a Windows Server 2003 running a instance of mysql 5.1.41-community MySQL Community Server (GPL). Start Mysql Workbench configure your localhost instance in the Server Administration part. Click in Server Administration.
[21 Apr 2010 3:34] Valeriy Kravchuk
Thank you for the problem report. Please, check with a newer version, 5.2.19, and inform about the results.
[29 Apr 2010 13:55] Alexandre Gomes
Tested with version 5.2.20 and still cannot start server administration through workbench.
Error details:

x32 on x32Traceback (most recent call last):

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_grt.py", line 200, in openAdministrator

    do_open_administrator(server_instance)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_grt.py", line 129, in do_open_administrator

    adminTab = AdministratorTab(server_instance)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_grt.py", line 90, in __init__

    self.ctrl_be = wb_admin_control_be.MyCtrl(server_instance_settings)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_control_be.py", line 584, in __init__

    if connect_sql and self.server_is_stopped_for_sure():

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_control_be.py", line 832, in server_is_stopped_for_sure

    return self.is_running()

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_control_be.py", line 850, in is_running

    result = self.exec_cmd(script, usesudo, password)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_control_be.py", line 928, in exec_cmd

    result = run_cmd(self.wrap_command(script, sudo), sudo, password)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_control_be.py", line 824, in wrap_command

    wcmd = "cmd.exe /C \"" + cmd + "\""

TypeError: cannot concatenate 'str' and 'NoneType' objects
[17 May 2010 12:07] Maksym Yehorov
Alexandre,
From the output you pasted I can assume that the server instance profile may not be valid. Please check start command in the the server instance profile editor. It is on 'System Profile' tab.
[20 May 2010 13:51] Maksym Yehorov
Duplicate of http://bugs.mysql.com/52383
[20 May 2010 17:05] Alexandre Gomes
Ok,
I put a configuration on 'System Profile' tab and it opened server administration.
Thanks.
[2 Jun 2010 15:03] Johannes Taxacher
this is a duplicate of Bug #52383