Bug #52950 Drop Table Does Not Refresh Workbench Object Browser
Submitted: 19 Apr 2010 17:16 Modified: 30 Aug 2010 21:34
Reporter: Paul Rudge Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.19 Beta, 5.2.26 OS:Microsoft Windows (XP SP3)
Assigned to: CPU Architecture:Any
Tags: Object Browser, Table Refresh
Triage: Needs Triage: D3 (Medium)

[19 Apr 2010 17:16] Paul Rudge
Description:
When Drop Table is selected (right click), only the bottom panel refreshes(Overview)

A manual refresh updates the Object Browser  (Left Panel)

The Object Browser, leaves the icon and just blanks the text.

Although not tested, it may also occur when droping other objects.

How to repeat:
Right click any table in either the Overview or Object panels and select DROP TABLE.

Suggested fix:
On DROP, refresh the Object Browser.
[19 Apr 2010 17:46] Valeriy Kravchuk
Does not happen to me on Mac OS X.
[19 Apr 2010 17:53] Miguel Solorzano
Thank you for the bug report. Are you able to illustrate this issue using screen-shot (attaching the files here).I wasn't able to repeat or maybe misunderstood the issue. Thanks in advance.
[19 Apr 2010 23:33] Paul Rudge
Three Test Tables

Attachment: 3Tables.PNG (image/x-png, text), 63.72 KiB.

[19 Apr 2010 23:34] Paul Rudge
After Delete - No Refresh

Attachment: NoRefresh.PNG (image/x-png, text), 63.64 KiB.

[19 May 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[28 Aug 2010 12:31] Sveta Smirnova
Thank you for the report.

Verified as described. In version 5.2.26 WB tries to refresh, but I still see icon of deleted table, but no name for it.
[30 Aug 2010 21:34] Alfredo Kojima
Duplicate of bug #52878