Bug #52836 Some unclear options/missing related documentations during monitor/agent install
Submitted: 14 Apr 2010 20:15 Modified: 24 May 2010 14:22
Reporter: Roel Van de Paar (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Installing Severity:S2 (Serious)
Version:2.2 OS:Microsoft Windows
Assigned to: Andy Bang CPU Architecture:Any

[14 Apr 2010 20:15] Roel Van de Paar
Description:
As per image.

How to repeat:
Installed MEM2.2 on Windows 7

Suggested fix:
As per image.
[14 Apr 2010 20:18] Roel Van de Paar
Unclear setup option, link to be updated, manual to be updated.

Attachment: MEM2.2 unclear setup option.png (image/png, text), 31.49 KiB.

[14 Apr 2010 20:20] Roel Van de Paar
(Notice text below image)
[19 Apr 2010 4:14] Roel Van de Paar
A similar issue in the agent installer: there is a screen which allows to select which "components to install" and it has a link saying "click here for more information", but the link just points to https://enterprise.mysql.com/docs/monitor/2.2/en/ instead of a related sub-page (see the image above for a similar example in the monitor installer)
[19 Apr 2010 4:16] Roel Van de Paar
In the agent installer, that same page says "Note that if you are using Connector/J or Connector/NET, no plug-in is necessary; they communicate directly with the Enterprise Dashboard". Should this note lists specific versions of the connectors? Otherwise one may think that "any Connector/J or Connector/NET can communicate with the dashboard directly"
[20 Apr 2010 6:59] MC Brown
Assigning to Andy - Docs team do not have control over the installer or where it links to.
[27 Apr 2010 22:23] Roel Van de Paar
One more small item during agent install (and at the same time merging in the [19 Apr 6:16] comment):

"I'm using MySQL Proxy to collect Query Analyzer data (the proxy plugin will be installed)"

How about changing this to two check boxes:

--------
Tickbox "Activate Query Analyzer" yes/no (default = yes)

 When this is ticked, a second box should be enabled for tick/untick:

  Sub/indented Tickbox "Install Poxy Plugin" yes/no (default = yes)
--------

And under this the following clarifying text:

Note: Connector/J version x.xx or higher & Connector/NET version x.xx or higher do not require the Proxy Plugin: they communicate directly with the MySQL Enterprise Monitor Server/Dashboard. However, if you do not use these connectors (or you are using an older version of them), you will require the Proxy Plugin to enable Query Analyzer functionality.
[27 Apr 2010 22:27] Roel Van de Paar
IMO, the above should be fixed before 2.2 goes GA.
[13 May 2010 23:53] Enterprise Tools JIRA Robot
Andy Bang writes: 
In build 2.2.1.1718.
[17 May 2010 0:24] Enterprise Tools JIRA Robot
Bill Weber writes: 
verified that more informative text and appropriate doc links were added to agent build 2.2.1717, and monitor build 2.2.1.1718
[24 May 2010 14:22] MC Brown
No changelog entry required (pre-release change); since the advice on separate servers also already exists, no other changes made.