Bug #52681 Server administration
Submitted: 8 Apr 2010 8:41 Modified: 8 Apr 2010 11:01
Reporter: Debijan Monster Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2.17 OS:Microsoft Windows (XP SP3)
Assigned to: CPU Architecture:Any
Tags: Administration, connect, server

[8 Apr 2010 8:41] Debijan Monster
Description:
Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Click on Server Administration to administrate localhost connection. After click a get an error windows/message. Error text is pasted in Description area of this bug report.
[8 Apr 2010 10:15] MySQL Verification Team
Thank you for the bug report. Could you please try version 5.2.17. Thanks in advance.
[8 Apr 2010 10:34] Debijan Monster
In 5.2.17 I dont get windows with error and nothing happens. But in status bar bottom left I get some text: 

"Error in wb.admin module: error calling WbAdmin.tmpAdministratorShortcut: see output for details"

And output windows says:

x32 on x32Traceback (most recent call last):

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_grt.py", line 248, in tmpAdministratorShortcut

    tab = do_open_administrator(server)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_grt.py", line 126, in do_open_administrator

    adminTab = AdministratorTab(server_instance)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_grt.py", line 87, in __init__

    self.ctrl_be = wb_admin_control_be.MyCtrl(server_instance_settings)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_control_be.py", line 662, in __init__

    if connect_sql and self.server_is_stopped_for_sure():

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_control_be.py", line 884, in server_is_stopped_for_sure

    return self.is_running()

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_control_be.py", line 899, in is_running

    result = self.exec_cmd(script, usesudo, password)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_control_be.py", line 969, in exec_cmd

    (script, filters) = build_filters(script)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_control_be.py", line 177, in build_filters

    idx = text.rfind('|')

AttributeError: 'NoneType' object has no attribute 'rfind'
[8 Apr 2010 11:01] MySQL Verification Team
Thank you for the feedback. Same as verified by bug: http://bugs.mysql.com/bug.php?id=52598.
[8 Apr 2010 15:11] MySQL Verification Team
Duplicate of bug: http://bugs.mysql.com/bug.php?id=52342.