Bug #52676 Blue Screen Error With system driver.
Submitted: 8 Apr 2010 3:07 Modified: 17 Jun 2010 11:34
Reporter: Jessica P Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.17, 5.2.19 OS:Microsoft Windows (XP Home Service Pack 3)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: Blue Screen Error.

[8 Apr 2010 3:07] Jessica P
Description:
The trouble I have with MySQL Workbench is that, If I am working in Workbench, and exit. On the subsequent start of the program and exiting using the File menus exit option both times on the subsequent exit a Blue Screen error occurs indicating a problem with the win32k.sys driver. And If this is a problem because Workbench communicates with this particular driver, Maybe this problem can be replicated. Also often this is after a MySQL connection has been established and the administration tasks completed. the problem lies in the exiting the application. I am using 

How to repeat:
Start MySQL Workbench Run a mock database administration task after a connection to a MySQL is established. exit using the File menu. Repeat this once more and this is usually when it happens for me

Suggested fix:
suggeted fix, would be to see if there is a bug in any code that communicates with any Kernel-Mode Drivers in the software.
[13 Apr 2010 1:23] Johannes Taxacher
Hi Jessica,

so your whole system crashes with a bluescreen when quitting WB?

could you provide the info shown when you select help->system info

thanks in advance
[13 Apr 2010 1:27] Jessica P
Yes the entire system crashes the info displayed is:
MySQL Workbench OSS for Windows version 5.2.17

Cairo Version: 1.8.8

Rendering Mode: OpenGL is not available on this system, INTERNAL ERROR, contact the authors.

OpenGL Driver Version: Not Detected

OS: Microsoft Windows XP Home Edition Service Pack 3 (build 2600)

CPU: Intel(R) Celeron(R) M processor         1.40GHz, 2.0 GiB RAM

Video adapter info:

Adapter type: Mobile Intel(R) 915GM/GMS,910GML Express Chipset Family

Chip Type: Intel(R) 915GM/GMS,910GML Express Chipset

BIOS String: Intel Video BIOS

Video Memory: 131072 KB
[16 Apr 2010 15:55] Miguel Solorzano
Could you please try version 5.2.18. Thanks in advance.
[17 Apr 2010 4:49] Jessica P
Hello, I followed your advice to update, I updated to 5.2.19 and once the install completed I used the "Launch after finish is pressed" option, After 45-60 seconds approximately the Blue screen stop error occured once more, Listing the same driver, win32k.sys, as the cause of the system crash. Hope this helps.
[20 Apr 2010 12:45] Johannes Taxacher
Hello Jessica,

please try launching WB using this command-line-parameter:
 -swrendering

we have seen a case like this in conjunction with an intel graphics board (and/or its drivers).
maybe you could try to update your graphic-card-driver. 
Especially the following line from your info output does hint at a problem with the openGL implementation:

Rendering Mode: OpenGL is not available on this system, INTERNAL ERROR, contact the
authors.
[25 Apr 2010 20:45] Jessica P
Hi sorry for the delay, the -swrendering command-line option seems to work for WB, And I will also try if possible to fix the OpenGL implementation issue. Thank you for all of your help, hope this is resolved in the stable release of WB, and I look forward to using it.
[12 May 2010 13:00] Born Crawl
I totally confirm this bug on WinXP SP3 with MySQL Workbench 5.2.20 OSS. command line switch -swrendering seems to help.
[12 May 2010 15:28] Valeriy Kravchuk
Please, check with a newer version, 5.2.21, and inform about the results.
[12 Jun 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[13 Jun 2010 2:07] Jessica P
I am not able to test WB at this time, Due to computer issues, Maybe if other WB users see and could help out with this bug, Sorry I was not able to get back to you.
[17 Jun 2010 11:34] Mike Lischke
This is one of several reports about the BSOD issue when running WB. This problem has been fixed a couple of weeks ago already.

Other reports: Bug #53522, Bug #53304