Bug #52672 MySQL product archive tarballs are corrupted
Submitted: 7 Apr 2010 22:21 Modified: 6 Mar 2013 10:08
Reporter: Justin Swanhart Email Updates:
Status: Closed Impact on me:
Category:MySQL Server: Packaging Severity:S1 (Critical)
Version:5.0.90, 5.0.87, maybe others OS:Linux
Assigned to: CPU Architecture:Any

[7 Apr 2010 22:21] Justin Swanhart
When I download any recent tarball from the archives, gzip tells me that the archive is not in gzip format:

For example
wget http://downloads.mysql.com/archives/mysql-5.0/mysql-5.0.90-linux-i686-glibc23.tar.gz
gzip -d mysql-5.0.90-linux-i686-glibc23.tar.gz:
gzip: mysql-5.0.90-linux-i686-glibc23.tar.gz: not in gzip format

wget http://downloads.mysql.com/archives/mysql-5.0/mysql-5.0.90-linux-i686-glibc23.tar.gz
gzip -d mysql-5.0.87-linux-i686-glibc23.tar.gz:
gzip: mysql-5.0.87-linux-i686-glibc23.tar.gz: not in gzip format

I've tried extracting on: 
CentOS 5.1
Debian 4.0
OSX Snow Leopard

How to repeat:
Download and try to extract the 5.0.90 or 5.0.87 tarballs.  I don't have the bandwidth to exhaustively check all of them.

Suggested fix:
make new tarballs
[8 Apr 2010 3:26] Valeriy Kravchuk
Looks like a duplicate of Bug #52639. Please, check.
[8 May 2010 23:01] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[27 Sep 2011 13:58] Joerg Bruehe
5.0.90 isn't current any longer, so this may be moot - but still:

I downloaded several 5.0.90 packages, including the "i686" one, from the archive
(URL: http://downloads.mysql.com/archives.php?p=mysql-5.0&v=5.0.90 )
and checked them locally:
- "tar tzv" succeeded for all those which I tried,
- and "md5sum" reported the same value as listed on the web page.

So this may have been an issue with the download mirrors,
the packages (as available on the MySQL servers) are ok.

That said, users of MySQL 5.0 should have switched to 5.1 for
some time already, and now the recommendation is to use MySQL 5.5
(if a GA version is wanted) or even 5.6.
[6 Mar 2013 10:08] Yngve Svendsen
We were unable to reproduce this issue.