Bug #52635 Expect workbench to report error 1242 and it reports OK
Submitted: 6 Apr 2010 21:13 Modified: 19 Apr 2010 20:44
Reporter: dwayne page Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.17 OSS Beta OS:Microsoft Windows (Windows 7 Ultimate)
Assigned to: CPU Architecture:Any
Tags: 1242, Scalar subquery

[6 Apr 2010 21:13] dwayne page
Description:
I expected workbench to report error 1242 (21000): Subquery returns more than one row.  It did not.

How to repeat:
 select Code c, Name
 From Country
 where 100 > (select Population
                    from City
                    where CountryCode = Country.Code);
 

Suggested fix:
Keep working your magic, God bless you for developing such great software.
[19 Apr 2010 20:44] Alfredo Kojima
This is a duplicate of Connector/C++ bug #52088
[15 Oct 2019 12:38] Fredric Johansson
This does not look like a duplicate of #52088 and it still affects recent releases of Workbench
[15 Oct 2019 12:57] Jon Armstrong
It's also not a workbench-only issue.  It's noticeable in the following fiddle due to the expected error not being noticed in the original response, but only after a show errors; is executed.  There's something odd in the way this error is reported in the response.  The command line client seems to notice the error.  It probably does something different than other clients.

https://dbfiddle.uk/?rdbms=mysql_8.0&fiddle=f866f3db461c943296a36dbaf8be65bd
[15 Oct 2019 13:04] Jon Armstrong
The above was tested in: MySQL 8.0.12.
[15 Oct 2019 13:09] Jon Armstrong
and 8.0.18