Bug #52625 Workbench does not bound LONGTEXT type fields
Submitted: 6 Apr 2010 17:57 Modified: 19 Apr 2010 13:02
Reporter: MySQL Blaser Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.18 OSS Beta OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any
Tags: workbench text edit

[6 Apr 2010 17:57] MySQL Blaser
Description:
Workbench is not putting single quotation marks around TEXT type fields (TEXT, MEDIUMTEXT, LONGTEXT) when editing SQL databases resulting in failed database commits.

A workaround is possible by manually editing the SQL statement to add the quotes before executing the SQL.

How to repeat:
Attempt to edit or write to a TEXT type field in Workbench
[6 Apr 2010 18:56] Valeriy Kravchuk
I do not see this problem with WB 5.2.17 on Mac OS X.
[6 Apr 2010 22:06] Godofredo Miguel Solorzano
Thank you for the bug report. I couldn't repeat against a 5.1.44 server and with TEXT column. Could you please attach a screen-shot showing that behavior on your side?. Thanks in advance.
[6 Apr 2010 22:41] MySQL Blaser
Apologies.  It appears to only be an issue with the LONGTEXT type, not the other TEXT types.  Try with that and see if you can replicate.
[6 Apr 2010 22:42] MySQL Blaser
Workbench is not putting single quotation marks around LONGTEXT type fields when editing SQL databases resulting in failed database commits.

A workaround is possible by manually editing the SQL statement to add the quotes before
executing the SQL.

How to repeat:
Attempt to edit or write to a TEXT type field in Workbench
[6 Apr 2010 22:46] MySQL Blaser
How to repeat:
Attempt to edit or write to a LONGTEXT type field in Workbench
[7 Apr 2010 5:25] Valeriy Kravchuk
I still do not see this problem with WB 5.2.17 on Mac OS X, even for LONGTEXT columns.
[7 Apr 2010 10:26] MySQL Blaser
OK I am not imagining this.  I have uploaded two screenshots, showing the datatypes of the table I am working on and the result of an attempted edit...
[16 Apr 2010 17:39] Godofredo Miguel Solorzano
Could you please try version 5.2.18 version. Thanks in advance.
[16 Apr 2010 18:26] MySQL Blaser
The problem still persists in 5.2.18
[19 Apr 2010 7:45] Susanne Ebrecht
Many thanks for writing a bug report. This is not a bug.

We can't set quotes by automatism because you could use keywords like DEFAULT, TRUE, FALSE or so that only will work without quotes.
[19 Apr 2010 13:02] MySQL Blaser
That sounds like wrongness to me.  How come the quotes are added for TEXT, TINYTEXT and MEDIUMTEXT then?