Bug #52584 RQG --debug does not work
Submitted: 4 Apr 2010 12:11 Modified: 6 Apr 2010 13:30
Reporter: Philip Stoev Email Updates:
Status: Closed Impact on me:
None 
Category:Tools: Random Query Generator Severity:S2 (Serious)
Version:2 OS:Any
Assigned to: Bernt Marius Johnsen CPU Architecture:Any

[4 Apr 2010 12:11] Philip Stoev
Description:
RQG --debug does not provide proper EXPLAIN summaries at the end.

This may be bacause in App::Gentest.pm , the Executor objects are created before the fork().

How to repeat:
run any grammar with --debug. The output will look like this:

# 2010-04-04T15:05:06 Statistics for Executor dbi:mysql:host=127.0.0.1:port=19300:user=root:database=test
# 2010-04-04T15:05:06 Rows returned:
$VAR1 = undef;
# 2010-04-04T15:05:06 Explain items:
$VAR1 = undef;
# 2010-04-04T15:05:06 Errors:
$VAR1 = undef;
# 2010-04-04T15:05:06 Rare EXPLAIN items:
$VAR1 = undef;
[6 Apr 2010 13:30] Bernt Marius Johnsen
Fixed. Caused by code relying an destructor. Fixed with explicit disconnect of executors"