Bug #52573 Cannot edit a New Layer
Submitted: 3 Apr 2010 17:45 Modified: 3 Apr 2010 17:56
Reporter: Cluesome McClue Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.17 beta OS:Mac OS X (10.6.2)
Assigned to: CPU Architecture:Any

[3 Apr 2010 17:45] Cluesome McClue
Description:
What I did:
I selected "Create new EER Model" from the front page Data Modelling options list.
I double clicked the Add Diagram function.
On the Edit Diagram tab I pressed the L (New Layer) key and dragged out a New Layer.
I double clicked on the new layer to select it for editing to change its' name.

What I expected to happen:
I expected the editor to pop up at the bottom of the screen with the New Layer tab selected.

What actually happened:
Nothing popped up.
Same if I right-mouse clicked and selected Edit Layer option - no result.

How to repeat:
Follow the "What I did" instructions above.

Suggested fix:
The workaround I found was to create a new table and then the New Layer tab appeared in the editor with the new table tab.
[3 Apr 2010 17:56] Cluesome McClue
My bad. I just needed to drag the window display up.
Not a bug.