Bug #52542 Cant load libndbclient.so : undefined symbol: __cxa_pure_virtual
Submitted: 1 Apr 2010 22:00 Modified: 31 Aug 2010 12:54
Reporter: Fabio Kaminski Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Cluster: Cluster/J Severity:S1 (Critical)
Version:7.1.2a-beta OS:Linux
Assigned to: CPU Architecture:Any
Triage: Triaged: D2 (Serious) / R6 (Needs Assessment) / E6 (Needs Assessment)

[1 Apr 2010 22:00] Fabio Kaminski
Description:
java.lang.UnsatisfiedLinkError: /usr/lib/mysql/lib/mysql/libndbclient.so.4.0.0: /usr/lib/mysql/lib/mysql/libndbclient.so.4.0.0: undefined symbol: __cxa_pure_virtual
	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1803)
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1728)
	at java.lang.Runtime.loadLibrary0(Runtime.java:823)
	at java.lang.System.loadLibrary(System.java:1028)
	at com.mysql.clusterj.tie.ClusterConnectionImpl.loadSystemLibrary(ClusterConnectionImpl.java:65)
	at com.mysql.clusterj.tie.ClusterConnectionImpl.(ClusterConnectionImpl.java:40)
	at com.mysql.clusterj.tie.ClusterConnectionServiceImpl.create(ClusterConnectionServiceImpl.java:30) ...

How to repeat:
trying to connect through java from OpenJpa with persistence.xml:

<property name="openjpa.ConnectionDriverName" value="com.mysql.jdbc.Driver"/>
		<property name="openjpa.ConnectionURL" value="jdbc:mysql://localhost:3306/test"/>
		<property name="openjpa.ConnectionUserName" value="root"/>
		<property name="openjpa.ConnectionPassword" value=""/>
		<property name="openjpa.BrokerFactory" value="ndb"/>
		<property name="openjpa.ndb.connectString" value="localhost"/>
		<property name="openjpa.ndb.verbose" value="1"/>
		<property name="openjpa.ndb.database" value="test"/>

Mysql cluster compiled from source with flags:

CFLAGS="-O3" CXX=gcc CXXFLAGS="-O3 -felide-constructors -fno-exceptions -fno-rtti"

./configure -prefix=/usr/lib/mysql --enable-assembler --with-mysqld-ldflags=-all-static --with-plugins=max --with-openjpa --with-classpath=/Mobly/Solucao/Bibliotecas/apache-openjpa-2.0.0-beta3/openjpa-2.0.0-beta3.jar:/Mobly/Solucao/Bibliotecas/apache-openjpa-2.0.0-beta3/lib/geronimo-jpa_2.0_spec-1.0.jar:/Mobly/Solucao/Bibliotecas/apache-openjpa-2.0.0-beta3/lib/geronimo-jta_1.1_spec-1.1.1.jar --with-extra-charsets=all

Linux X86_64 : Ubuntu 10
[6 Apr 2010 3:20] Alexey Kishkin
it looks like duplicate of http://bugs.mysql.com/bug.php?id=51642