Bug #52504 Synchronize Model problem: nothing appear when using different schema name
Submitted: 31 Mar 2010 13:55 Modified: 1 Apr 2010 9:51
Reporter: Andrea Dellamonica Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.16 Revision 5249 OS:Microsoft Windows (Windows 7 Professional)
Assigned to: CPU Architecture:Any
Tags: processed, schema, synchronize, workbench

[31 Mar 2010 13:55] Andrea Dellamonica
Description:
This Problem appear when try to use the Synchronize Model and connecting to local or host MySQL server schema with different schema name.

Menu:
- Connections Options (OK)
- Connect to DBMS (OK)
  Retrieve Schema List from Database (OK)
  Fetch finished
- Select Schemata to be processed (nothing appear and cant chose the schema to compare)

Next button disabled

How to repeat:
Install Revision 5349 and create a new schema with a different name of the schema to compare, try to Synchronize.

Suggested fix:
Work if the name for schema are the same. Can be a good feature if we can chose witch schema to compare.
[31 Mar 2010 13:59] Andrea Dellamonica
Synchronize Model - Select Schemata

Attachment: problem.png (image/png, text), 61.84 KiB.

[1 Apr 2010 6:25] Susanne Ebrecht
Many thanks for writing a bug report.

MySQL server is not supporting something "RENAME SCHEMA".

MySQL workbench is only supporting what MySQL server 5.1 supports.
[1 Apr 2010 9:51] Andrea Dellamonica
I know that, but the problem is that you cant compare a schema with another that has a different name.