Bug #52477 Workbench OutOfMemory exception
Submitted: 30 Mar 2010 13:21 Modified: 30 Mar 2010 16:38
Reporter: Tony Walker Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.16 OSS OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any

[30 Mar 2010 13:21] Tony Walker
Description:
I exported data in my schema to a dump file (37Mb)
Tried to load the resulting SQL script into the SQL editor and got told out of memory error 'System.OutOfMemoryException'

Full details of error:
Exception = System.OutOfMemoryException
Message = Exception of type 'System.OutOfMemoryException' was thrown.
FullText = System.OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown.
   at System.String.GetStringForStringBuilder(String value, Int32 startIndex, Int32 length, Int32 capacity)
   at System.Text.StringBuilder..ctor(String value, Int32 startIndex, Int32 length, Int32 capacity)
   at System.Windows.Forms.Control.get_WindowText()
   at System.Windows.Forms.Control.set_CacheTextInternal(Boolean value)
   at System.Windows.Forms.Control.PerformLayout(LayoutEventArgs args)
   at System.Windows.Forms.Control.System.Windows.Forms.Layout.IArrangedElement.PerformLayout(IArrangedElement affectedElement, String affectedProperty)
   at System.Windows.Forms.Layout.LayoutTransaction.DoLayout(IArrangedElement elementToLayout, IArrangedElement elementCausingLayout, String property)
   at System.Windows.Forms.Control.OnResize(EventArgs e)
   at System.Windows.Forms.Control.OnSizeChanged(EventArgs e)
   at System.Windows.Forms.Control.UpdateBounds(Int32 x, Int32 y, Int32 width, Int32 height, Int32 clientWidth, Int32 clientHeight)
   at System.Windows.Forms.Control.UpdateBounds()
   at System.Windows.Forms.Control.WmWindowPosChanged(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at ScintillaNet.Scintilla.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
As Above
[30 Mar 2010 13:44] Valeriy Kravchuk
Thank you for the problem report. What exact version of MySQL Workbench, 5.2.x, do you use? Please, send also the results from Help > System Info menu item.
[30 Mar 2010 13:56] Tony Walker
Help/System Info:
MySQL Workbench OSS for Windows version 5.2.16
Cairo Version: 1.8.8
Rendering Mode: OpenGL requested (create a diagram to confirm)
OpenGL Driver Version: 1.5.0 - Build 6.14.10.4873
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
CPU: 2x Intel(R) Core(TM)2 Duo CPU     T5670  @ 1.80GHz, 2.0 GiB RAM
Video adapter info:
Adapter type: Mobile Intel(R) 965 Express Chipset Family
Chip Type: Mobile Intel(R) 965 Express Chipset Family
BIOS String: Intel Video BIOS
Video Memory: 393216 KB
[30 Mar 2010 16:38] MySQL Verification Team
Duplicate of bug: http://bugs.mysql.com/bug.php?id=51606.