Bug #52411 Many connect failures while running the test suite on Windows
Submitted: 27 Mar 2010 21:29 Modified: 27 Apr 2010 7:30
Reporter: Joerg Bruehe Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Windows Severity:S3 (Non-critical)
Version:5.5.3-m3 OS:Microsoft Windows (both 32 and 64 bit)
Assigned to: CPU Architecture:Any
Triage: Triaged: D2 (Serious)

[27 Mar 2010 21:29] Joerg Bruehe
Description:
This is from the 5.5.3-m3 release build:

While running the test suite, many tests fail because the client cannot connect to the server, either at the start of a test or when making a new connection within a test.

This is an example of the latter kind:

=====
main.grant2                              [ fail ]
        Test ended at 2010-03-25 09:53:46

CURRENT_TEST: main.grant2
mysqltest: At line 181: query 'connect  con8,127.0.0.1,root,,test,$MASTER_MYPORT,' failed: 2003: Can't connect to MySQL server on '127.0.0.1' (10061)

The result from queries just before the failure was:
< snip >
ERROR 42000: SELECT command denied to user 'mysqltest_1'@'localhost' for column 'b' in table 't1'
grant select on t1 to mysqltest_3@localhost;
ERROR 42000: SELECT command denied to user 'mysqltest_1'@'localhost' for table 't1'
drop table t1;
delete from mysql.user where user like 'mysqltest\_%';
delete from mysql.db where user like 'mysqltest\_%';
delete from mysql.tables_priv where user like 'mysqltest\_%';
delete from mysql.columns_priv where user like 'mysqltest\_%';
flush privileges;
drop database mysqltest;
use test;
create user mysqltest_1@host1;
create user mysqltest_2@host2;
create user mysqltest_3@host3;
create user mysqltest_4@host4;
create user mysqltest_5@host5;
create user mysqltest_6@host6;
create user mysqltest_7@host7;
flush privileges;
drop user mysqltest_3@host3;
=====

At first, I suspected load issues or other non-reproducible machine trouble, but I then noticed it happens on the very same tests for both the 32 and the 64 bit Windows build.
This makes the bugs so reproducible that the reason must be inherent to our tests, setup, or binaries.

How to repeat:
Run the test suite.

For a full list, please see the 5.5.3-m3 build logs.
[27 Apr 2010 7:30] Alexander Nozdrin
This is a duplicate of Bug#52381.