Bug #52333 Clicking Import/Export causes Workbench to crash
Submitted: 24 Mar 2010 14:49 Modified: 24 Mar 2010 15:14
Reporter: Brandon Williams Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:5.2.16 OSS Beta Revision 5249 OS:Microsoft Windows (XP Professional SP3)
Assigned to: CPU Architecture:Any
Tags: import export

[24 Mar 2010 14:49] Brandon Williams
Description:
Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
From the Home tab, under 'Server Administration', click Manage Import/Export, select a database, click 'Ok', and the above exception is thrown immediately.
[24 Mar 2010 14:50] Valeriy Kravchuk
What exact version of MySQL server, x.y.z, local or remote, are you working with?
[24 Mar 2010 14:55] Brandon Williams
MySQL Version 5.0.19-standard over Standard TCP/IP Connection.
[24 Mar 2010 15:14] Miguel Solorzano
Thank you for the bug report. Duplicate of bug: http://bugs.mysql.com/bug.php?id=51477.