Bug #52328 Workbench error
Submitted: 24 Mar 2010 13:11 Modified: 24 Mar 2010 13:51
Reporter: John McNair Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.15 OSS Beta OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[24 Mar 2010 13:11] John McNair
Description:
Exception = System.AccessViolationException
Message = Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
FullText = System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at Sql_editor.check_sql(Sql_editor* , shared_ptr<Sql_editor>* , Boolean )
   at MySQL.Grt.Db.Sql.Sql_editor.check_sql()
   at MySQL.Grt.Db.Sql.SqlEditor.CheckSyntax()
   at MySQL.Grt.Db.Sql.SqlEditor.BackgroundActionTimer(Object obj, EventArgs args)
   at System.Windows.Forms.Timer.OnTick(EventArgs e)
   at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
pasted a large number (2,000) of update statements into SQL Editor.
[24 Mar 2010 13:51] MySQL Verification Team
Thank you for the bug report. Duplicate of bug: http://bugs.mysql.com/bug.php?id=51606.