Bug #523 MySQL ODCB 3.51 driver drops MySQL tables using querries from MS Access
Submitted: 28 May 2003 6:22 Modified: 8 Jul 2003 0:37
Reporter: Kuzz Email Updates:
Status: Not a Bug Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:3.51 OS:Microsoft Windows (WIndows Platforms)
Assigned to: Bugs System CPU Architecture:Any

[28 May 2003 6:22] Kuzz
Description:
I beleive this is a bug

Here is how to replicate it:

I create a table in MySQL, then i set up a  user that IS NOT ALLOWED to drop tables. Then I set up my ODCB connection to MySQL database with that 
same user name and password. Then I go in MS Access and set up a passthrough query (again, it is using the user login and passowrd with no drop rights). In the passthrough query i write <<drop table mytable;>> and  guess what happens when i run the querry. The table gets dropped. Looking forward for anybody's reply.

How to repeat:
same way

Create a table in MySQL, then set up a  user that IS NOT ALLOWED to drop tables. Then set up my ODCB connection to MySQL database with that 
same user name and password. Go to MS Access and set up a passthrough query (again, it is using the user login and passowrd with no drop rights). In the passthrough query write <<drop table mytable;>> Run the querry, see what happens. PLEASE DROP A FOO TABLE. I do not want to be held accountable for your loss, if it happens.

If you are using NTFS on W2K WINNT and later, make sure the table files, are not delete protected.

Suggested fix:
got no clue. I am a mear MS Access DB developer learning MySQL and PHP
[28 May 2003 7:56] Venu Anuganti
Hi !! 
 
Looks like the user privileges are not appropriate. Even if you connect from MySQL command 
line utility using the same user, you might be able to drop the table as you specified. The 
reason for this, driver doesn't do anything for this, and it just passes the query to server. 
 
Could you please cross check the user privileges. 
 
Thanks 
Venu
[8 Jul 2003 0:37] Venu Anuganti
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem is not the result of a bug.
For a list of more appropriate places to ask for help using MySQL
products, please visit http://www.mysql.com/support/

Thank you for your interest in MySQL.