Bug #52218 read_only_innodb crashes the server
Submitted: 19 Mar 2010 13:31 Modified: 19 Mar 2010 13:42
Reporter: Alexander Nozdrin Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: General Severity:S3 (Non-critical)
Version:6.0 OS:Any
Assigned to: Ingo Strüwing CPU Architecture:Any
Tags: disabled

[19 Mar 2010 13:31] Alexander Nozdrin
Description:
$./mtr read_only_innodb

...

#0  __pthread_kill (threadid=<value optimized out>, signo=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/pthread_kill.c:63
#1  0x0000000000bc92df in my_write_core (sig=6) at stacktrace.c:328                                                                  
#2  0x0000000000713667 in handle_segfault (sig=6) at mysqld.cc:2843                                                                  
#3  <signal handler called>                                                                                                          
#4  0x00007f8ad37f44b5 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64                      
#5  0x00007f8ad37f7f50 in *__GI_abort () at abort.c:92                                                                               
#6  0x00007f8ad37ed481 in *__GI___assert_fail (assertion=0xd888c8 "(table->lock_position < mylock->table_count) && (table == lock_tables[table->lock_position])", file=<value optimized out>, 
    line=779, function=0xd89300 "TABLE_LIST* mysql_lock_have_duplicate(THD*, TABLE_LIST*, TABLE_LIST*)") at assert.c:81                                                                       
#7  0x0000000000708fdb in mysql_lock_have_duplicate (thd=0x2860de8, needle=0x28a9f88, haystack=0x0) at lock.cc:778                                                                            
#8  0x0000000000782ec3 in unique_table (thd=0x2860de8, table=0x28a9f88, table_list=0x0, check_alias=true) at sql_base.cc:1880                                                                 
#9  0x00000000007e1653 in mysql_prepare_insert (thd=0x2860de8, table_list=0x28a9f88, table=0x26e4908, fields=..., values=0x28aa540, update_fields=..., update_values=..., duplic=DUP_ERROR,   
    where=0x7f8aca3869d8, select_insert=false, check_fields=false, abort_on_warning=false) at sql_insert.cc:1356                                                                              
#10 0x00000000007dfa9f in mysql_insert (thd=0x2860de8, table_list=0x28a9f88, fields=..., values_list=..., update_fields=..., update_values=..., duplic=DUP_ERROR, ignore=false)               
    at sql_insert.cc:668
#11 0x000000000072916a in mysql_execute_command (thd=0x2860de8) at sql_parse.cc:3390
#12 0x000000000073097b in mysql_parse (thd=0x2860de8, inBuf=0x28a9ea0 "INSERT INTO temp1 VALUES (10)", length=29, found_semicolon=0x7f8aca388838) at sql_parse.cc:6060
#13 0x0000000000723c4a in dispatch_command (command=COM_QUERY, thd=0x2860de8, packet=0x27382b9 "INSERT INTO temp1 VALUES (10)", packet_length=29) at sql_parse.cc:1091
#14 0x000000000072301b in do_command (thd=0x2860de8) at sql_parse.cc:775
#15 0x0000000000720fa2 in do_handle_one_connection (thd_arg=0x2860de8) at sql_connect.cc:1173
#16 0x0000000000720e58 in handle_one_connection (arg=0x2860de8) at sql_connect.cc:1113
#17 0x0000000000c89920 in pfs_spawn_thread (arg=0x278d8a8) at pfs.cc:1011
#18 0x00007f8ad4938a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#19 0x00007f8ad38a080d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#20 0x0000000000000000 in ?? ()

How to repeat:
Run read_only_innodb.
Found on Linux x86_64 (Ubuntu 9.10)
[19 Mar 2010 13:36] Alexander Nozdrin
Disabling the test case due to this bug.
[19 Mar 2010 13:40] MySQL Verification Team
I couldn't repeat on Fedora 12 X86_64 with mysql-6.0:

==============================================================================

TEST                                      RESULT   TIME (ms)
------------------------------------------------------------

worker[1] Using MTR_BUILD_THREAD 300, with reserved ports 13000..13009
main.read_only_innodb                    [ pass ]    530
------------------------------------------------------------
The servers were restarted 0 times
Spent 0.530 of 7 seconds executing testcases

All 1 tests were successful.

[miguel@hegel mysql-test]$ cat /etc/issue
Fedora release 12 (Constantine)
Kernel \r on an \m (\l)
[19 Mar 2010 13:42] Alexander Nozdrin
Closed as a duplicate of Bug#52114.