Bug #52184 Crash While Closing Application
Submitted: 18 Mar 2010 15:35 Modified: 19 Mar 2010 11:10
Reporter: Richard Mah Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.16 OSS Beta Rev/5249 OS:Microsoft Windows (XP Professional SP3)
Assigned to: CPU Architecture:Any

[18 Mar 2010 15:35] Richard Mah
Description:
Exception = System.InvalidOperationException
Message = SplitterDistance must be between Panel1MinSize and Width - Panel2MinSize.
FullText = System.InvalidOperationException: SplitterDistance must be between Panel1MinSize and Width - Panel2MinSize.
   at System.Windows.Forms.SplitContainer.set_SplitterDistance(Int32 value)
   at MySQL.GUI.Workbench.MainForm.mainDockPanel_ActiveDocumentChanged(Object sender, EventArgs e)
   at WeifenLuo.WinFormsUI.Docking.DockPanel.OnActiveDocumentChanged(EventArgs e)
   at WeifenLuo.WinFormsUI.Docking.DockPanel.FocusManagerImpl.RefreshActiveWindow()
   at WeifenLuo.WinFormsUI.Docking.DockPanel.FocusManagerImpl.ResumeFocusTracking()
   at WeifenLuo.WinFormsUI.Docking.DockPanel.ResumeLayout(Boolean performLayout, Boolean allWindows)
   at WeifenLuo.WinFormsUI.Docking.DockContentHandler.Close()
   at MySQL.GUI.Workbench.MainForm.MainForm_FormClosing(Object sender, FormClosingEventArgs e)
   at System.Windows.Forms.Form.OnFormClosing(FormClosingEventArgs e)
   at System.Windows.Forms.Form.WmClose(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
I don't know...I was just closing the application.
[19 Mar 2010 11:10] Johannes Taxacher
this looks vey much like a duplicate of Bug #52144