Bug #52147 --with-plugin-PLUGIN unrecognized option
Submitted: 17 Mar 2010 17:07 Modified: 18 Mar 2010 10:21
Reporter: BJ Dierkes Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:5.1.43+ OS:Linux (Red Hat Enterprise Linux 5)
Assigned to:

[17 Mar 2010 17:07] BJ Dierkes
Description:
The ./configure --help output lists an option called '--with-plugin-PLUGIN' where 'PLUGIN' is the name of a plugin to link into mysqld.  However, this option is bogus:

[wdierkes@220805-mock00 mysql-5.1.45]$ ./configure --with-plugin-partition --with-plugin-federated
configure: WARNING: unrecognized options: --with-plugin-partition, --with-plugin-federated

How to repeat:
$ ./configure --with-plugin-partition --with-plugin-federated
[17 Mar 2010 18:09] Valerii Kravchuk
I do not see this problem with current 5.1.46 from bzr:

77-52-28-202:mysql-5.1 openxs$ ./configure --with-plugin-partition 2>&1 | grep -i partition
checking whether to use Partition Support... yes
77-52-28-202:mysql-5.1 openxs$
[18 Mar 2010 10:21] Sveta Smirnova
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Duplicate of bug #42872