Bug #52140 search for function on the documentation page does not work well
Submitted: 17 Mar 2010 14:37 Modified: 11 May 2010 15:34
Reporter: Cyril SCETBON Email Updates:
Status: Closed Impact on me:
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: Paul DuBois CPU Architecture:Any
Tags: documentation, regression, search

[17 Mar 2010 14:37] Cyril SCETBON

when I try to search for 'CREATE TRIGGER' or 'CREATE TRIGGER SYNTAX' in the search for box it does not work in 5.1 documentation or 5.5 documentation even if the page exists. However it works in 5.0 documentation. Maybe indexes are not built the same manner ? Here are the results I get in versions 5.1, 5.0 and 5.5

5.1 :

MySQL :: MySQL 5.1 Reference Manual :: 12.5.5 SHOW Syntax
proc_name SHOW CREATE TABLE tbl_name SHOW CREATE TRIGGER trigger_name SHOW ...

    MySQL :: MySQL 5.1 Reference Manual :: Privileges Index
    ... 15, “ CREATE PROCEDURE and CREATE FUNCTION Syntax” Section 12.1.17, “ CREATE TABLE
    Syntax” Section 12.1.19, “ CREATE TRIGGER Syntax” Section 12.1.20 ...
    [ More results from dev.mysql.com/doc/refman/5.1 ] 

5.0 :

MySQL :: MySQL 5.0 Reference Manual :: 12.1.11 CREATE TRIGGER ...
... MySQL 5.0 Reference Manual :: 12 SQL Statement Syntax :: 12.1 Data Definition
Statements :: 12.1.11 CREATE TRIGGER Syntax. ... 12.1.11. CREATE TRIGGER Syntax. ...

    MySQL :: MySQL 5.0 Reference Manual :: 12.1.18 DROP TRIGGER Syntax
    ... TRIGGER foo_trigger_deleter; END IF; END// DELIMITER ; call foo_trigger_deleter();
    DROP PROCEDURE foo_trigger_deleter; CREATE TRIGGER foo_trigger BEFORE INSERT ...
    [ More results from dev.mysql.com/doc/refman/5.0 ] 

5.5 :

MySQL :: MySQL 5.5 Reference Manual :: 12.1.26 RENAME TABLE Syntax
... using RENAME TABLE , then the statement fails with the error Trigger in wrong ... the
ALTER and DROP privileges on the original table, and the CREATE and INSERT ...

    MySQL :: MySQL 5.5 Reference Manual :: RESIGNAL Syntax
    ... is not in a handler: CREATE TRIGGER t_bi BEFORE INSERT ON t FOR EACH ROW
    RESIGNAL; But it does not matter. RESIGNAL does not have ...

How to repeat:
try it :



[17 Mar 2010 14:38] Cyril SCETBON
I made a bad choice in the category. Corrected
[17 Mar 2010 15:02] Valeriy Kravchuk
Thank you for the bug report (I consider this a bug). Verified just as described.
[22 Mar 2010 8:48] Stefan Hinz
Thanks for the report! This is something that needs to be fixed by our Web team. I've filed a request, and will leave this bug open until this is resolved.
[23 Mar 2010 8:26] Stefan Hinz
Resolved by our striving Web team.
[23 Mar 2010 9:01] Cyril SCETBON
when you say fixed, that's to say it's in production ? 
cause if I seach for create trigger syntax it's still not working in 5.5 

[23 Mar 2010 13:59] Stefan Hinz
Reopening because apparently the bug has not yet been fixed for the 5.5 Manual. :-( Sorry for not testing this before closing the bug!
[30 Mar 2010 8:58] Stefan Hinz
I've filed another request with our Web team (who is handling the search) because the problem with the Google Appliance not finding the relevant pages is still there. Sorry for the inconvenience!
[11 May 2010 14:06] Stefan Hinz
This has been fixed; see: http://search.mysql.com/search?q=CREATE+TRIGGER&site=refman-51&btnG=Search&sort=date%3AD%3...
[11 May 2010 14:14] Cyril SCETBON
still not found in 5.5 documentation :(
[11 May 2010 14:32] Valeriy Kravchuk
What's wrong with the results at:

[11 May 2010 14:36] Stefan Hinz
What's wrong is that there's no search result pointing to http://dev.mysql.com/doc/refman/5.5/en/create-trigger.html.

I've filed another web request -- apparently, for a *few* versions of the Manual the respective pages don't show up in search results.
[11 May 2010 15:34] Cyril SCETBON
thanks !