Bug #52108 remote administration instance fails
Submitted: 16 Mar 2010 18:27 Modified: 22 Mar 2010 22:04
Reporter: Diego Turriaga Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2.16 revision 5249 OS:Microsoft Windows (XP SP3)
Assigned to: CPU Architecture:Any
Tags: Connection, remote, server administration, workbench

[16 Mar 2010 18:27] Diego Turriaga
Description:
In my HOST y have installed:
 - WinXP SP3
 - MySQL Client 5.1.11
 - MySQL QueryBrowser 1.2.17
 - MySQL Administrator 1.2.17
 - MySQL workbench 5.2.16 (here makes me error)

and in my Server:
 - Win2003 Server
 - MySQL essential 5.1.44 (TCP-IP)
 - MySQL workbench 5.2.16 (here, using localhost, works me fine)

When I'm try to open a remote administration instance fails and show me this error message:
  Exception = System.Runtime.InteropServices.SEHException
  Message = Un componente externo produjo una excepción.
  FullText = System.Runtime.InteropServices.SEHException: Un componente externo produjo una excepción.
     en MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
     en System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
     en System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
     en System.Windows.Forms.Control.WndProc(Message& m)
     en System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
     en System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
     en System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
easy:
1) create a new server instance for administration
2) click on "Server Administration"
3) select instance created and click on "OK" button
note: I'm trying to connect to a Windows domain network usign the IP from the MySQL server.

Suggested fix:
the same for the "query analizer" option (SQL Developement) works well.
[16 Mar 2010 19:30] Diego Turriaga
tip: "Manage Server Instance" > "System Profile" apears disabled
[22 Mar 2010 22:04] Johannes Taxacher
duplicate of bug # 51476