Bug #52052 Exception thrown making connection to newly defined connections & servers
Submitted: 15 Mar 2010 0:10 Modified: 15 Mar 2010 15:22
Reporter: John McClenahan Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2.16 OSS beta OS:Microsoft Windows (Windows 7 64bit)
Assigned to: CPU Architecture:Any
Tags: System.Runtime.InteropServices.SEHException, Windows 64bit

[15 Mar 2010 0:10] John McClenahan
Description:
1st time tried:
Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

2nd time tried
Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Just changing from MySQL Admin and Query Browser to Workbench, on new Windows 7 Home Premium 64 bit system.

Set up new connection, specified URL, username and pw, default port 3306, specified default database to use. Save pw to Vault. "Test connection" works. Opted (first time through) for Advanced/ Use SSL connection if available.

Clicked on Server Administration for this connection - crash with message as above.

Tried again, deleting Server Instance and original connection. 

New Connection again - url, username, pw, default database, default port.

This time clicked on Manage Import/Export.

Same result - crash - with second Exception report above.

I CAN connect to this database with Open Connection to Start Querying, and that DOES work - I can query a table and see the results.

Pity, I needed a backup, but it will have to wait. 

It seems similar but not identical to other reported bugs with Windows - can't connect to Server. I can't see a workaround in the bug reports I've looked at.

MySQL server is on CentOS 5.3 v5.0.77, on the local network.

Same result connecting to another MySQL server, on remote server, MySQL 4.1.22-log reported in the connection wizard.

Looks probably that it is a problem with Windows, perhaps only Win 7?
[15 Mar 2010 13:32] Miguel Solorzano
Thank you for the bug report. Duplicate of bug: http://bugs.mysql.com/bug.php?id=51477.
[15 Mar 2010 15:22] John McClenahan
Thanks for pointing out the duplicate bug reports - I'm sorry, but I didn't find them when trying to search for similar ones - perhaps I didn't look for the right search terms.

I have also tried installing and then 'Run as administrator' which sometimes fixes this kind of problem, but it makes no difference. Windows 7 64 bit reports a warning triangle and says 'incompatible program' or something similar (sorry, I can't remember the exact wording), for both the msi installer and the installed Workbench program, when I tried the installation Troubleshooter.

A pity, since I was hoping to be able to use the new Workbench as a replacement for GUI Tools (which incidentally still DO work under Windows 7).