Bug #52049 Cannot connect to server instance and open admin panel
Submitted: 14 Mar 2010 16:29 Modified: 15 Apr 2010 15:55
Reporter: Yinyin Liao Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:5.2.18-rev5648 OS:Mac OS X (10.6.2)
Assigned to: CPU Architecture:Any

[14 Mar 2010 16:29] Yinyin Liao
Description:
* I configured SSH access with an account which cannot write to /etc/my.cnf (could not have such access because of IT security rule in my environment)

* Double click on the created instance but cannot open admin panel

* Output in terminal as follows:

$ /Applications/MySQLWorkbench.app/Contents/MacOS/MySQLWorkbench
 Debug level - 0

** (process:449): WARNING **: :718: link 'com.mysql.wb.menu.view.advanced' <object app.MenuItem> key=owner could not be resolved
2010-03-15 00:20:32.729 MySQLWorkbench[449:903] *** WARNING: Method selectRow:byExtendingSelection: in class NSOutlineView is deprecated. It will be removed in a future release and should no longer be used.
** Message: function call error
Traceback (most recent call last):
  File "/Applications/MySQLWorkbench.app/Contents/PlugIns/wb_admin_grt.py", line 149, in openAdministrator
    do_open_administrator(server_instance)
  File "/Applications/MySQLWorkbench.app/Contents/PlugIns/wb_admin_grt.py", line 125, in do_open_administrator
    adminTab = AdministratorTab(server_instance)
  File "/Applications/MySQLWorkbench.app/Contents/PlugIns/wb_admin_grt.py", line 95, in __init__
    self.configuration = wb_admin_configuration.WbAdminConfiguration(server_instance_settings, self.ctrl_be, self.monitor)
  File "/Applications/MySQLWorkbench.app/Contents/PlugIns/wb_admin_configuration.py", line 60, in __init__
    sys_config_path = self.ctrl_be.get_config_file_path()
  File "/Applications/MySQLWorkbench.app/Contents/PlugIns/wb_admin_control_be.py", line 667, in get_config_file_path
    return self.expand_path_variables(self.settings.serverInfo['sys.config.path'].strip(" \r\t\n\b"))
AttributeError: 'NoneType' object has no attribute 'strip'

How to repeat:
* Create a server instance without configure SSH access.

* Double click on the created instance to open admin panel.

* Status bar will show that "Could not connect to target daabase: error calling WbAdmin.openAdministrator: see output for details"

* If open WB from Terminal.app, the trace information will shown in terminal window.
[18 Mar 2010 20:47] Lukas Faber
same problem here ...

installed Workbench v5.2.16 rev5249 on windows 7. Everything was fine at the beginning and I was able to use the server administration without SSH. I needed to use the Migration tool yesterday so I installed the old GUI Tools. Since that moment I am not able to open those server instances anymore ... the status bar is showing 'Could not connect to target database: error calling WbAdmin.openAdministrator: see output for details' ... I don't know how to get the 'output' on a windows machine though. Tried to uninstall and re-install again ... makes no difference. Still the same error message.
[26 Mar 2010 12:39] Susanne Ebrecht
How do you configure your my.cnf without using workbench?
[26 Mar 2010 14:22] Yinyin Liao
The MySQL server I try to connect is running on a debian linux PPC machine and is installed via apt-get.

The version of mySQL server is "5.0.32-Debian_7etch10-log". The my.cnf is mostly default value which comes with the debian package except that the IT admin allows MySQL server bind to 0.0.0.0 instead of 127.0.0.1 for management over network.

I used to connect to the same MySQL server with the MySQL Administrator in the MySQL GUI Tools Bundle without problem.
[1 Apr 2010 10:56] Susanne Ebrecht
MySQL 5.0 is very old and unsupported.

More about this you will find here:

http://www.mysql.com/about/legal/lifecycle/

Please try with actual server version (5.1.45).
[15 Apr 2010 15:52] Yinyin Liao
Just tested WB 5.2.18 beta2 against MySQL server 5.0 (5.0.32-Debian_7etch10-log) and 5.1 (5.1.37-1ubuntu5.1).

Now I can login into Admin panel without problem.
[15 Apr 2010 15:55] Yinyin Liao
Sorry, I am not sure its beta2 or beta8...

Anyway, it is the latest beta release I can obtain and the revision number is "5.2.18-rev5648".