Bug #52021 got bug message when clicking on a server instance in Server administration
Submitted: 12 Mar 2010 21:55 Modified: 22 Mar 2010 22:03
Reporter: william asher Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.16 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[12 Mar 2010 21:55] william asher
Description:
Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
click on server instance in Server Administration
[12 Mar 2010 23:13] Miguel Solorzano
Thank you for the bug report. Could you please provide te output of Help->System Info, have you created already a server instance (it is remote or local)?. Thanks in advance.
[15 Mar 2010 13:43] william asher
System Info:
x32 on x32Traceback (most recent call last):
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_grt.py", line 240, in tmpAdministratorShortcut
    tab = do_open_administrator(server)
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_grt.py", line 125, in do_open_administrator
    adminTab = AdministratorTab(server_instance)
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_grt.py", line 95, in __init__
    self.configuration = wb_admin_configuration.WbAdminConfiguration(server_instance_settings, self.ctrl_be, self.monitor)
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_configuration.py", line 60, in __init__
    sys_config_path = self.ctrl_be.get_config_file_path()
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_control_be.py", line 667, in get_config_file_path
    return self.expand_path_variables(self.settings.serverInfo['sys.config.path'].strip(" \r\t\n\b"))
AttributeError: 'NoneType' object has no attribute 'strip'
MySQL Workbench OSS for Windows version 5.2.16
Cairo Version: 1.8.8
Rendering Mode: OpenGL requested (create a diagram to confirm)
OpenGL Driver Version: 2.1.1
OS: Microsoft Windows XP Professional Service Pack 2 (build 2600)
CPU: 2x Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz, 2.0 GiB RAM
Video adapter info:
Adapter type: NVIDIA Quadro NVS 135M
Chip Type: Quadro NVS 135M
BIOS String: Version 60.86.68.00.16
Video Memory: 262144 KB

Miguel asked if I have created a "server instance".  Yes I did.  It is local.  The error occurs when I click on the server instance and then click on OK (after first clicking on Server Administration, of course).

I realize this program is a Beta version.  I would have stuck with MySQL workbench 5.1, but it didn't appear to have any SQL editing capability.
[22 Mar 2010 22:03] Johannes Taxacher
duplicate of bug # 51476