Bug #51953 Problem trying to print-preview
Submitted: 11 Mar 2010 13:59 Modified: 1 Apr 2010 19:38
Reporter: Jordan Thompson Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.2.16 Beta OS:Microsoft Windows
Assigned to: Assigned Account CPU Architecture:Any
Tags: documentation, hard-copy, Output, print

[11 Mar 2010 13:59] Jordan Thompson
Description:
I tried to print-preview my schema and got this error:

Exception = System.ArgumentException
Message = Parameter is not valid.
FullText = System.ArgumentException: Parameter is not valid.
   at System.Drawing.Image.get_RawFormat()
   at System.Drawing.Graphics.IgnoreMetafileErrors(Image image, Int32& errorStatus)
   at System.Drawing.Graphics.DrawImage(Image image, Int32 x, Int32 y, Int32 width, Int32 height)
   at System.Drawing.Graphics.DrawImage(Image image, Rectangle rect)
   at System.Windows.Forms.PrintPreviewControl.OnPaint(PaintEventArgs pevent)
   at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer, Boolean disposeEventArgs)
   at System.Windows.Forms.Control.WmPaint(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.PrintPreviewControl.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
print-preview
[1 Apr 2010 19:38] Johannes Taxacher
this is most likely a duplicate of Bug #49488