Bug #51947 Connect to server for administration
Submitted: 11 Mar 2010 9:53 Modified: 22 Mar 2010 22:02
Reporter: Nicolas Fischer Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:5.2.16 beta rev 5249 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[11 Mar 2010 9:53] Nicolas Fischer
Description:
I registered a server at the MySQL Workbench.

Using this connection for "SQL Development" is working.

When I try to manage the instance with "Server Administration" en exception appears after MySQL Workbench asks me to select the instance to manage.

Here is the exception:

Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
The exception appears everytime I try to connect to a server instance to manage it.
After the exception appears the process terminates so that I'm not able to manage a server instance using MySQL Workbench
[11 Mar 2010 22:42] Miguel Solorzano
Thank you for the bug report. Are you trying to connect to a local server or remote server?. Thanks in advance.
[12 Mar 2010 23:31] Nicolas Fischer
Sorry for missing this part.

The MySQL instance is on a different host. The other host is in the same LAN and the connection to it is 1GE.
I am using the FQDN of the machine to connect to it instead of the IP-Address only.

The network configuration (my client, the computer with the MySQL server instance and the network services) should be fine, because in parallel to trying the Workbench I am using the MySQL Administrator to connect from my machine to the other MySQL instance. This is working fine.
[14 Mar 2010 11:04] Valeriy Kravchuk
What exact version of MySQL server, x.y.z, are you trying to work with?
[16 Mar 2010 7:31] Nicolas Fischer
I'm using MySQL 5.1.42 community. I try to connect via TCP/IP
[22 Mar 2010 22:02] Johannes Taxacher
duplicate of Bug #51476