Bug #51871 Comments on table level are incorrectly compared with Model
Submitted: 9 Mar 2010 14:08 Modified: 10 Mar 2010 8:09
Reporter: Bart Baeyens Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.16 OS:Microsoft Windows (XP SP3)
Assigned to: CPU Architecture:Any

[9 Mar 2010 14:08] Bart Baeyens
Description:
A TABLE comment like "Gestionnaire/Beheerder" entered in the model (without the " ) is probably stored correctly in the database (as i can see with a query "SELECT table_comment FROM `information_schema`.`TABLES` where table_name like 'a212_admin%'" Result "Gestionnaire/Beheerder; InnoDB free: 287744 kB") but when comparing catalogs (using Live database server versus Model Schemata) the file contains differences for each comment:

Table `MY212`.`a212_admin_platform_entry` was modified	
  attributes:
  - comment: 'Gestionnaire/Beheerde --> Gestionnaire/Beheerder
  __

Also, when i want to see the comment on the Database (using right click context menu-item "alter table") i see "'Gestionnaire/Beheerde" instead of "Gestionnaire/Beheerder"

How to repeat:
Whatever comment entered in the model, when comparing it later on between Database and model, the comparison tool indicates a difference.
[9 Mar 2010 14:25] Valeriy Kravchuk
Looks like a duplicate of bug #51765. Please, check.
[10 Mar 2010 7:40] Bart Baeyens
Is indeed equal to 51765 !
[10 Mar 2010 8:09] Susanne Ebrecht
This is a duplicate of bug #51765