Bug #51863 Difference in SELECT output for large floating-pt numbers on SunOS and Linux
Submitted: 9 Mar 2010 11:33 Modified: 17 Mar 2010 16:48
Reporter: Nirbhay Choubey Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version:5.1.44 OS:Any
Assigned to: Paul Dubois CPU Architecture:Any
Triage: Needs Triage: D3 (Medium)

[9 Mar 2010 11:33] Nirbhay Choubey
Description:
Executing the following set of statements show 
difference in output of SELECT :

DROP TABLE IF EXISTS t1;
CREATE TABLE t1(c1 FLOAT(53,0), c2 FLOAT(53,0));
INSERT INTO t1 VALUES('1e+52','-1e+52');
SELECT * FROM t1;
DROP TABLE t1;

Output for select -
On Linux              : inf     -inf
On SunOS(5.10/sparc)  : 0       -0

How to repeat:
See description.
[9 Mar 2010 12:44] Valeriy Kravchuk
On Windows with 5.1.43 I get even 1 and -1, so what? Results for FLOAT will depend on libraries implementation and platform. Why do you think that there is a bug here?
[9 Mar 2010 13:26] Nirbhay Choubey
I feel 0/-0 is inappropriate here, but if its 'platform/implementation dependent' please mark it as not a bug.
[9 Mar 2010 16:51] Valeriy Kravchuk
While these different results on different platforms are expected with FLOAT, I'd still prefer to see this clearly documented as a note, with examples, somewhere at http://dev.mysql.com/doc/refman/5.1/en/numeric-types.html.
[17 Mar 2010 16:48] Paul Dubois
Thank you for your bug report. This issue has been addressed in the documentation. The updated documentation will appear on our website shortly, and will be included in the next release of the relevant products.

Added note about issue to:
http://dev.mysql.com/doc/refman/5.1/en/numeric-types.html
with cross-reference for more information to:
http://dev.mysql.com/doc/refman/5.1/en/problems-with-float.html