Bug #51784 Exception after defining new server instance
Submitted: 5 Mar 2010 20:51 Modified: 22 Mar 2010 21:51
Reporter: Ed Eaglehouse Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:5.2.16 OSS OS:Microsoft Windows (Vista 32-bit)
Assigned to: CPU Architecture:Any
Tags: Administration, Connection, exception, server

[5 Mar 2010 20:51] Ed Eaglehouse
Description:
Received the following exception when attempting to open a new connection to a server instance:

Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I defined a new connection to my server via SSH. When I activated the connection to access it, an error message popped up saying, MySQL Workbench has encountered a problem.

Once the error appears, the Workbench appears to lock up if I try to establish a connection in SQL Development (same server settings). Otherwise, the development connection allows me to access the schemas in the database.

How to repeat:
1. Define a new server instance. SSH login-based administration was disabled.
2. Select the connection from the list.
3. Click the Server Administration link.
4. In the popup list, select the connection again. Click the OK button.
5. See error popup. The above stack trace is from the "Copy Bug Info to Clipboard" button.

Suggested fix:
I don't have any, other than perhaps more descriptive error messages. This is my first experience using SQL Workbench.
[5 Mar 2010 20:53] Ed Eaglehouse
The connection was a Standard TCP/IP over SSH. The same settings are what I used for an SQL Development connection that works.
[9 Mar 2010 12:28] Valeriy Kravchuk
What exact MySQL server version, x.y.z, are you trying to work with?
[9 Mar 2010 15:25] Ed Eaglehouse
I am attempting to connect to MySQL version 5.1.32 running on a Solaris 10 server.

My server is available only through SSH. I could take down the firewall temporarily if you wanted me to test something.
[10 Mar 2010 10:06] Susanne Ebrecht
How do you run Solaris commands like "ps" from your Windows machine on the Solaris machine without using ssh?
[11 Mar 2010 14:43] Ed Eaglehouse
I can open a Telnet port through my firewall to open a terminal session if necessary. Do you suspect there is something incompatible with SSH?
[22 Mar 2010 21:51] Johannes Taxacher
this is most likely a duplicate of the problem in Bug #51476