Bug #51668 unable to administer server
Submitted: 3 Mar 2010 1:10 Modified: 22 Mar 2010 21:49
Reporter: Pete Porzuczek Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.16 5249 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[3 Mar 2010 1:10] Pete Porzuczek
Description:
Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Startup Workbench (5.2.16 OSS beta rev 5249), created "manage server instance",  entered login info, etc.  SSH Box NOT checked.  Tested connection and that worked.  Clicked Ok from setup popup, then selected server instance name from "server administration" list, and clicked on the "Server Administration" link.  A few moments after clicking I got an exception popup.

Additional information:  I was able to create a "New Connection" and query without issue.   When I created the "Manage Server Instance", I used the same settings as defined in the "New Connection" settings.
[3 Mar 2010 4:25] Valeriy Kravchuk
Thank you for the problem report. What exact version of Windows do you use? What version of MySQL server (local or remote?) are you connecting to?
[3 Mar 2010 17:21] Pete Porzuczek
Additional information regarding this bug;

I am connecting to a remote dedicated server running IIS 6.0, MySQL 5.0.   I do run MySQL Administrator and am able to connect and admin the database via that platform without issue.
[4 Mar 2010 12:12] Susanne Ebrecht
Did you configure ssh connection correct?
[4 Mar 2010 20:24] Pete Porzuczek
SSH checkbox was NOT selected.  I attempted to setup SSH initially, but it was unclear as to what credentials should be entered in this area....the database credentials or the remote server login credentials.  I tried both and both failed to connect on test, so I continued with setup without enabling the SSH option.  There was no SSH option available in the original MySQL Administrator application, so my belief was that the SSH information within workbench was not required either.
[5 Mar 2010 10:05] Susanne Ebrecht
MySQL server 5.0 is very old and already out of support.

Did you have same error by using MySQL server 5.1?
[6 Mar 2010 23:28] Pete Porzuczek
I am looking into upgrading version 5.0 to 5.1 but the database is on a production server and getting the upgrade done may take some time.  In the meantime, since many sites most likely still use 5.0 by virtue of their hosting accounts, this bug should be addressed to some degree for version 5.0 administration.  

As far a enabling SSH, I am unclear as to the credentials necessary to connect.  Should the credentials be the database access credentials or the server admin credentials (eg. credentials used to remote into the server)?  Perhaps I can get connected with SSH enabled and that may narrow things down a bit.
[10 Mar 2010 11:18] Susanne Ebrecht
Sorry, but we have a strict life cycle which you will find here:
http://www.mysql.com/about/legal/lifecycle/

Your problems could be related to using server 5.0.

Workbench is not made for server 5.0. It is only for server 5.1 and higher.

According to http://bugs.mysql.com/how-to-report.php

"If the product is crashing, include a backtrace."

We would need this backtrace for deeper analysis.
[10 Mar 2010 15:43] Pete Porzuczek
Since you won't investigate this bug, my suggestion is that you check server versions and if someone is attempting to use Workbench against server versions lower than 5.1, you disallow it.   In addition, you should provide archived access to the "older" SQL admin and query manager so those not in a position to upgrade immediately have a fallback to a tool that will work with their installation.
[17 Mar 2010 12:31] Adrian Murariu
I have exact error as described by Pete.

Also, I AM NOT USING SSH FOR SERVER CONNECTION!!!

I am using Workbench on a Windows XP Professional SP3 and MySQL servers I want to connect to are version 5.1.42 and 5.1.37.

I can work with old MySQL Admin tool with no problem.
[22 Mar 2010 21:49] Johannes Taxacher
sorry for the delay, but this is most likely a duplicate of Bug #51476