Bug #51575 The MySql Connector .Net 6.2.2 Setup Wizard Ended Prematurely
Submitted: 27 Feb 2010 15:21 Modified: 1 Mar 2010 7:13
Reporter: Tim Odell Email Updates:
Status: Not a Bug Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.2.2 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: installer

[27 Feb 2010 15:21] Tim Odell
Description:
Intallation fails with this message.

The MySql Connector .Net 6.2.2 Setup Wizard Ended Prematurely.

MySQL Connector Net 6.2.2 Setup Wizard ended prematurely because of an error.  Your system has not been modified.  To install this program at a later time, run setup wizard again.  Click the finish button to exit the Setup Wizard.

How to repeat:
Download mysql-connector-net-6.2.2.zip as of today.

Unzip

double click 

mysql.data.msi

select complete or any other option

watch wizard fail.  Seems to fail when registering some type of provider
[27 Feb 2010 15:23] Tim Odell
Additional info: I am installing Windows 7 Ultimate 32 bit
[27 Feb 2010 15:30] Tim Odell
I am Running Custom Installation with each option individually to isolate the problem:

The following installed:
-------------------------------
Core Components 
Documentation
Entity Framework Support
Compact Framework Support
Visual Studio Integration
Samples

The following failed to install:
-------------------------------
Web Providers
[27 Feb 2010 19:46] Tim Odell
looking thru my machine.config i found previous references to mysql and deleted them.  The msi was then able to install the web providers.

Visual studio was still not connecting so i then uninstalled everything and ran the msi installer again.  now it works.  grrrr..
[1 Mar 2010 7:13] Tonci Grgin
Tim, it might be useful to use default uninstall procedure provided by windows to be sure you removed everything from the last install...

Other than that, I'm doing this on weekly basis (uninstall/install 5.x, 6.x) on W2K8SEx64 box with both VS2005Pro and VS2008Pro and haven't had any troubles in months.
[25 Apr 2010 15:24] Alex Galashov
the same with 6.3.0 (alpha?)
After i changed from 2010 RC1 to 2010 Ultimate the providers in studio stopped working. Applications still work.
i could not uninstall the connector,
"Mysql connector NET 6.3.0 setup ended prematurely because of an error...".
Then: i removed it from installed programs list with msicuu2.exe.
Removed all references from machine.config.
Tried to install 6.3.0, 6.3.1 - the same.

Installed 6.2.2 - success
uninstalled it. 
Still 6.3.0 and 6.3.1 did not install.
installed 6.2.3...

mysql data connections in 2010 still does not work. gonna reinstall windows...