Bug #51570 Create Table context menu item does not work for existing tables (sql editor)
Submitted: 27 Feb 2010 0:17 Modified: 16 Apr 2010 14:09
Reporter: Bob Dankert Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.16 Rev 5249 OS:Microsoft Windows (W7 64)
Assigned to: Sergei Tkachenko CPU Architecture:Any
Tags: CREATE TABLE, menu, sql editor

[27 Feb 2010 0:17] Bob Dankert
Description:
In the SQL editor, the "Create Table" context menu item does not work when you right click on an existing table.  The menu that pops up offers several options, including "Alter Table", "Create Table", and "Drop Table".  Both Alter Table and Drop Table work fine, but Create Table is missing.  It seems as though the MenuItem Click event was never assigned.

This functionality does work if you right click on the "Tables" folder and use this context menu - only the existing table context menu has issues.

How to repeat:
Click on the "Create Table" context menu item for an existing table in the SQL editor.

Suggested fix:
Map the menu item click event to the correct routine for creating a new table.
[1 Apr 2010 20:29] Johannes Taxacher
Bug #52387 has been marked as duplicate of this one
[12 Apr 2010 23:47] Johannes Taxacher
fix confirmed in repository
[16 Apr 2010 14:09] Tony Bedford
An entry has been added to the 5.2.18 changelog:

In the Object Explorer of the Sidebar, if an existing table was right-clicked, the context-sensitive menu displayed the option Create Table.... However, selecting this option appeared to have no effect.