Bug #51522 exception when attempting to manage a remote server that has no ssh access
Submitted: 25 Feb 2010 18:14 Modified: 1 Mar 2010 22:10
Reporter: Mathew Keister Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:5.2.16 OS:Microsoft Windows (Windows 7 x64 Ultimate)
Assigned to: CPU Architecture:Any
Tags: Amazon aws RDS no ssh remote instance administrator connect

[25 Feb 2010 18:14] Mathew Keister
Description:
When attempting to use workbench to administer a remote server that has no ssh access, exception thrown on trying to launch server administration.

Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Using an Amazon RDS remote mysql instance; no ssh access, just mysql access on port 3306. set up server connection, attempt to connect with server administrator, exception thrown.

Suggested fix:
Older mysql administrator GUI works fine, however workbench server administrator does not seem to work on remote servers that do not have ssh access.
[25 Feb 2010 18:33] MySQL Verification Team
Thank you for the bug report. Please see if related to bug:

http://bugs.mysql.com/bug.php?id=51522

Thanks in advance.
[25 Feb 2010 18:34] Mathew Keister
You linked me to my own bug to see if it was related.
[25 Feb 2010 22:44] MySQL Verification Team
Sorry I meant: http://bugs.mysql.com/bug.php?id=51483. Thanks in advance.
[25 Feb 2010 22:48] Mathew Keister
The exception message is the same, however the conditions are completely different. Since the exception is a generic external component message (compent not reporting the underlying error, just a general error message) and the conditions are so different, I would say that it is safe to assume the two issues are different.
[26 Feb 2010 7:42] Susanne Ebrecht
Hello Matthew,

please tell me how do you configure my.cnf and start/stop the remote server without using Workbench?
[27 Feb 2010 23:35] Mathew Keister
My particular instance is using Amazon RDS, so I modify parameters and start / stop the service via their API.

However I still use the old GUI administrator app to manage users and schemas, as well as monitor health variables, connections, and do some backup work.
[1 Mar 2010 22:10] Johannes Taxacher
This is a duplicate of Bug #51476