Bug #51485 Can't start node at DBDICT
Submitted: 25 Feb 2010 7:24 Modified: 28 Jul 2016 17:52
Reporter: Mikiya Okuno Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S2 (Serious)
Version: OS:Any
Assigned to: Bogdan Kecman CPU Architecture:Any
Triage: Triaged: D2 (Serious) / R5 (Severe) / E6 (Needs Assessment)

[25 Feb 2010 7:24] Mikiya Okuno
Description:
A data node fails during start phase 4 after system (non-initial) restart.

Time: Thursday 25 February 2010 - 10:28:15
Status: Temporary error, restart node
Message: Internal program error (failed ndbrequire) (Internal error, programming error or missing error message, please report a bug)
Error: 2341
Error data: dbdict/Dbdict.cpp
Error object: DBDICT (Line: 3791) 0x0000000a
Program: ndbmtd
Pid: 2356 thr: 0
Version: mysql-5.1.39 ndb-7.0.9b
Trace: /mysql/log/data/ndb_11_trace.log.14 /mysql/log/data/ndb_11_trace.log.14_t1 /mysql/log/data/ndb_11_trace.log.14_t2 /mysql/lo

How to repeat:
- Insert 2.5M rows
- Shutdown the cluster (Normal shutdown)
- Restart the cluster (Non-initial)
- The node fails at start phase 4

Suggested fix:
no idea
[23 Mar 2010 7:47] Jonas Oreland
Hi,

The code fails as it open() returns no-such-file or directory
when trying to open a DATAFILE.

Have you
1) modified content in FileSystemPath
2) modified values in config for FileSystemPath (or FileSystemPathDD ...)
[12 Oct 2010 1:53] Mikiya Okuno
Hi Jonas,

I did neither of them, but errno 2 was returned. It sounds like a mystery ;)

Kind regards,
Mikiya
[10 Nov 2010 0:01] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[28 Jul 2016 17:52] Bogdan Kecman
can't reproduce on any of the modern releases 7.2.24, 7.4.11