Bug #51477 Workbench crash when attempting to connect
Submitted: 24 Feb 2010 22:37 Modified: 26 Mar 2010 10:39
Reporter: Carter Terry Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2.16 OS:Linux (CentOS 5.4/Windows)
Assigned to: Alfredo Kojima CPU Architecture:Any

[24 Feb 2010 22:37] Carter Terry
Description:
Workbench crashes when attempting to connect to a server for "Manage Import / Export"

How to repeat:
Successfully created a Server Instance and then highlighted it and clicked Manage Import / Export. A pop-up box asking to "Select Server to Connect to:" which I selected (there was only one in the list) and clicked the OK button. Immediately, a new window popped up saying "MySQL Workbench has encountered a problem, External component has thrown an exception."
[25 Feb 2010 8:33] Valeriy Kravchuk
What exact version of MySQL Workbench, 5.x.y, do you use?
[25 Feb 2010 17:24] Carter Terry
Hi Valeriy,

I am using MySQL Workbench 5.2.16 OSS Beta Revision 5249 against MySQL Server 5.0.77 (comes packaged with CentOS 5.4).

Thanks,
CARTER
[1 Mar 2010 14:52] Miguel Solorzano
Thank you for the feedback. The connection is for a local or remote server?. Thanks in advance.
[2 Mar 2010 23:47] Miguel Solorzano
Bug:http://bugs.mysql.com/bug.php?id=51665 marked as duplicate of this one.
[3 Mar 2010 16:58] Carter Terry
The connection was to a remote server. Basically from my Windows Vista x64 workstation running MySQL Workbench to a CentOS Linux 5.4 server running MySQL server.
[3 Mar 2010 21:39] Miguel Solorzano
Please disregard the duplicate comment I did before.
[3 Mar 2010 21:40] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=51665 marked as duplicate of this one.
[3 Mar 2010 21:43] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=51703 marked as duplicate of this one.
[4 Mar 2010 12:24] Alberto León
I has the same problem, for remote server too. I paste the throw error.

Exception = System.Runtime.InteropServices.SEHException
Message = Un componente externo produjo una excepción.
FullText = System.Runtime.InteropServices.SEHException: Un componente externo produjo una excepción.
   en MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   en System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   en System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   en System.Windows.Forms.Control.WndProc(Message& m)
   en System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   en System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   en System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
[4 Mar 2010 18:07] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=51733 marked as duplicate of this one.
[9 Mar 2010 12:43] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=51800 marked as duplicate of this one.
[9 Mar 2010 14:22] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=51870 marked as duplicate of this one.
[9 Mar 2010 23:25] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=51895 marked as duplicate of this one.
[11 Mar 2010 22:25] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=51963 marked as duplicate of this one.
[11 Mar 2010 22:45] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=51944 marked as duplicate of this one.
[12 Mar 2010 18:45] Johannes Taxacher
Bug #51999 has been marked as a duplicate of this one
[15 Mar 2010 13:33] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=52052 marked as duplicate of this one.
[22 Mar 2010 12:24] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=52262 marked as duplicate of this one.
[26 Mar 2010 10:39] Tony Bedford
An entry has been added to the 5.2.17 changelog (and duplicates recorded):

When Manage Import / Export was clicked on the Home screen, a server instance selected, and then OK clicked, MySQL Workbench displayed an error dialog with the following message:

MySQL Workbench has encountered a problem, External component has thrown an
exception.
[29 Mar 2010 12:28] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=52423 marked as duplicate of this one.
[12 Jun 2011 14:01] Alex Seif
Are there any updates on this bug? I have the same issue but mostly when i connect to a remote database.