Bug #51368 MySQL Workbench Unexpected Error
Submitted: 21 Feb 2010 15:39 Modified: 22 Mar 2010 13:33
Reporter: Jørgen Johanson Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2.16 OSS beta OS:Microsoft Windows (Windows 7 Ultimate x64 / Vista Ultimate x86)
Assigned to: Alfredo Kojima CPU Architecture:Any

[21 Feb 2010 15:39] Jørgen Johanson
Description:
Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Define a server instance.
Test to see if OK.
Click "Server Administration".
Select instance just defined.
Click "OK".

It is not possible to get Server Administration to work.
[21 Feb 2010 15:42] Jørgen Johanson
Since it is not possible to use Server Administration at all, I changed the Severity from Non-Critical to Critical.
[21 Feb 2010 16:52] Valeriy Kravchuk
I can not repeat this on 32-bit XP. Should be something 64-bit/Windows 7 related.
[21 Feb 2010 20:53] Jørgen Johanson
Its 100% repeatable here. BTW, I finally managed to track down MySQL Administrator (version 1.2.17). Connecting to the same database (remote), everything works as I am used to (even under Windows 7 x64).

I just tested MySQL Workbench 5.2.16.OSS beta also on my Windows Vista Ultimate x32 machine. Same result:

Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
[22 Feb 2010 8:16] Tonci Grgin
Jørgen, can you please try to start WB as follows:
  "C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 OSS\MySQLWorkbench.exe" -swrendering
(-swrendering being the important part) and let us know if it helps.
[22 Feb 2010 8:53] Jørgen Johanson
OK, looks like I am getting the same "MySQL Workbench Unexptected Error" on both systems (Win 7 x64 and Vista x86. Could I be doing something wrong here?):

On Windows 7 x64:

"C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 OSS\MySQLWorkbench.exe" -swrendering 

Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

On Vindows Vista x86:

"C:\Program Files\MySQL\MySQL Workbench 5.2 OSS\MySQLWorkbench.exe" -swrendering

Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
[22 Feb 2010 9:18] MySQL Verification Team
I tried this with Vista Home Premium (32 bit) monitoring a localhost 5.0 server and couldn't repeat the problem.
[22 Feb 2010 9:31] Jørgen Johanson
Can it have something to do with the (remote) database? Here is the database I am using as a test (the application using it works OK and I can connect just fine with MySQL Administrator (version 1.2.17) on both systems):

    Server: rooftoptravel.mysql.domeneshop.no
    Database: rooftoptravel
    Username: rooftoptravel
    Password: mBppx8bu

Feel free to give it a try (its not doing anything critical at the moment).
[22 Feb 2010 9:32] Tonci Grgin
Jørgen, unfortunately, I was unable to repeat the problem on my Win7x64 Ultimate VM (using -swrendering cause of running WB in VM) ie. I see my managed server and can move around.

Now, what *appears* to me regarding this exception, is that there is a call to unmanaged routines from managed code and we're not be able to get better view of the problem as it's CRT dependent. So I'll inform WB devs to take a look into this now.

In the meantime, you might wish to run C:\Windows\System32\psr.exe and attach resulting file describing your problem.
[22 Feb 2010 9:45] Tonci Grgin
Verified as described using steps described by Jørgen and his server info.
[22 Feb 2010 10:06] Jørgen Johanson
psr.exe file 'bug-data-51368.zip' uploaded to ftp://ftp.mysql.com/pub/mysql/upload/
[16 Mar 2010 2:07] Alfredo Kojima
Problem is fixed, from my understanding, the issue is with any server instance that was created with the New Instance wizard with SSH disabled. At least I am unable to repeat the bug after this fix.
[22 Mar 2010 9:52] Johannes Taxacher
fix confirmed in repository
[22 Mar 2010 13:33] Tony Bedford
An entry has been added to the 5.2.17 changelog:

If a server instance was created with the New Instance wizard with SSH disabled, then the following exception occurred when attempting to administer the server instance:

Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an
exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32
clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam,
IntPtr lparam)
[29 Mar 2010 13:59] MySQL Verification Team
Bug: http://bugs.mysql.com/bug.php?id=52299 marked as duplicate of this one.