Bug #51292 Error Selecting "Manage Import/Export" From Home Screen
Submitted: 18 Feb 2010 19:43 Modified: 22 Mar 2010 21:43
Reporter: Josh McCullough Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:5.2.16 OSS Beta r5249 OS:Microsoft Windows ( Windows 7 x86)
Assigned to: CPU Architecture:Any

[18 Feb 2010 19:43] Josh McCullough
Description:
Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_click(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Select "Manage Import/Export" from home screen after adding first instance of server.
[18 Feb 2010 21:07] Miguel Solorzano
I couldn't repeat on Windows Vista Ultimate X64.
[18 Feb 2010 21:09] Josh McCullough
FYI this occurred on Windows 7 x86. I can't get to the import/export functionality at all - this error occurs each time.
[19 Feb 2010 10:04] Valeriy Kravchuk
Do you have any server instances defined?
[19 Feb 2010 16:06] Josh McCullough
I first added a server/connection using the "New Server Instance" wizard. After that, I got the bug when I would try to Import/Export. Then I removed the server/connection manually via "Manage Server Instances" and re-added it manually. Now, I get a bit farther (no errors).
[22 Mar 2010 21:43] Johannes Taxacher
marked as a duplicate of Bug #51476