Bug #51260 can't check a column when creating a foreign key in the table editor
Submitted: 18 Feb 2010 0:46 Modified: 9 Mar 2010 10:36
Reporter: Shaolin 1 Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:5.2.16 Beta OS:Any
Assigned to: CPU Architecture:Any
Tags: check, column, foreign key, table editor
Triage: Needs Triage: D2 (Serious)

[18 Feb 2010 0:46] Shaolin 1
Description:
I can't check the Column in table editor when I'm creating new foreign key. It depends on Referenced Table, resp. its schema. When I choose table1 in schema1 it works, I can check the Column. When I choose table1 in schema2 (the copy of schema1) I can't select the Column neither the Referenced Column.

How to repeat:
SQL Editor/Overview/Alter table.../Foreign Keys/

1. fill Foreign Key Name
2. select Referenced Table
3. check Column (sometimes it doesn't work)
[18 Feb 2010 8:42] Susanne Ebrecht
Verified as described.

You are not able to draw a model that will show you this:

CREATE SCHEMA employees;
USE employees;
CREATE TABLE employees(
i INTEGER NOT NULL
name VARACHAR(100) NOT NULL,
address VARACHAR(100) NOT NULL,
PRIMARY KEY(i));

CREATE SCHEMA bug;
USE bug;
CREATE TABLE bug(
i INTEGER NOT NULL,
employee_worked_on_bug INTEGER NOT NULL,
PRIMARY KEY (i),
FOREIGN KEY(employee_worked_on_bug) REFERENCES employee.employee(i));

The whole SQL schema logic seems to be missing in Workbench diagram.
[18 Feb 2010 15:16] Shaolin 1
Maybe you found another problem, but I don't understand what you mean. I don't use diagram. I'm using Table editor as described here: http://dev.mysql.com/doc/workbench/en/wb-table-editor.html#wb-table-editor-foreign-keys-ta... .

I've found where was the problem. Sorry, it was my mistake. I was trying to reference a column which was not exactly the same. One column was signed and the second column was unsigned.