Bug #51252 archive tables still fail under stress tests: crash, corruption, 4G memory alloc
Submitted: 17 Feb 2010 18:48 Modified: 15 Feb 2012 3:02
Reporter: Shane Bester (Platinum Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Archive storage engine Severity:S1 (Critical)
Version:5.1.43, 5.1.45-bzr OS:Any
Assigned to: CPU Architecture:Any
Tags: archive, corruption, crash, valgrind
Triage: Needs Triage: D1 (Critical)

[17 Feb 2010 18:48] Shane Bester
Description:
crashes, corruptions, out of memory due to 2^31 byte allocation still happen with archive tables under concurrent dml/ddl.

there are numerous bugs here, each one should be fixed and testcase rerun and next problem fixed, in steps.

How to repeat:
run mysqld under valgrind.
compile/run "bug47012.c" from bug #47012

this testcase from bug #47012 must run for minimum of 1 hour and preferably 10 threads against mysqld under valgrind without any warnings before we may consider this bug fixed.
[18 Feb 2010 13:33] Valeriy Kravchuk
I've easily got error 145 with that test case (10 threads) on recent 5.1.45-debug built from mysql-5.1 bzr tree.
[30 Apr 2010 14:38] Shane Bester
just to clarify, that testcase does concurrent insert,select,analyze,show columns,optimize,check table,alter table,flush table,checksum table, on 4 pretty nasty looking tables.
[1 May 2010 7:58] Shane Bester
this is a superset of bug #37280
[22 Apr 2011 17:10] Valeriy Kravchuk
Bug #50632 was marked as a duplicate of this one.
[15 Feb 2012 3:02] Paul Dubois
Noted in 5.5.18, 5.6.4 changelogs. 

ARCHIVE tables with NULL columns could cause server crashes or become 
corrupt under concurrent load.